Mailinglist Archive: opensuse (933 mails)

< Previous Next >
Re: [opensuse] building rpm packages and automatic dependencies.
  • From: Michael Andres <ma@xxxxxxx>
  • Date: Tue, 1 Jun 2010 14:31:54 +0200
  • Message-id: <201006011431.55321.ma@xxxxxxx>
On Monday 31 May 2010 17:55:16 mailing lists wrote:
Hello,

I need build some packages but I'm unable to understand how to override
automatic dependencies.

You (usually) don't want to.

Anyone knows how to solve this?

# zypper install -r 1 haproxy
Retrieving repository 'Opensuse11.2-local' metadata [done]
Building repository 'Opensuse11.2-local' cache [done]
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: nothing provides libpcreposix.so.0()(64bit) needed by
haproxy-1.4.4-1.x86_64 Solution 1: do not ask to install a solvable

try 'zypper install --from 1 haproxy'
(-r, --repo should IMO be deprecated).

The --repo flaw is that it uses the specified repo only, i.e. packages from
other repos are not visible, thus not available to satisfy dependencies.

With --from the package is also taken from your repo, but missing dependencies
may be satisfied by using packages from other repos too.

This might solve your problem if package libpcreposix0 is not available in
your 'Opensuse11.2-local' repo, but in some other.

--

cu,
Michael Andres

+------------------------------------------------------------------+
Key fingerprint = 2DFA 5D73 18B1 E7EF A862 27AC 3FB8 9E3A 27C6 B0E4
+------------------------------------------------------------------+
Michael Andres ZYPP Development ma@xxxxxxx
SUSE LINUX Products GmbH, GF: Markus Rex, HRB 16746 (AG Nuernberg)
Maxfeldstrasse 5, D-90409 Nuernberg, Germany, ++49 (0)911 - 740 53-0
+------------------------------------------------------------------+

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages