Mailinglist Archive: opensuse (1596 mails)

< Previous Next >
[opensuse] installing yum for installing cpanel-->"...was not able to locate the glibc package.."
Dear my friends...

I want to install cpanel on my OpenSuSE 11.1.

What I've done is:
1. Because the cpanel works with "yum" or "apt-get", so I chose yum and
install it:
1.1. I found the repository with webpin.
1.2. put them into yast repository
1.3. and install the yum with yast.

2. I did: "cd /srv/www/htdocs/cpanel".
3. I did:
"
wget http://layer1.cpanel.net/latest
".
4. I did:
"
sh latest
".
5. And I am stucked on this:
"
sussy:/srv/www/htdocs/cpanel # sh latest
Creating directory installd
Verifying archive integrity... All good.
Uncompressing
cplyr1-cPanel............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
____ _
___| _ \ __ _ _ __ ___| |
/ __| |_) / _` | '_ \ / _ \ |
| (__| __/ (_| | | | | __/ |
\___|_| \__,_|_| |_|\___|_|

Installer Version 11.5.1



Beginning main installation.
Your operating system's rpm update method (yum) was not able to locate the
glibc package. This is an indication of an improper setup. You must correct
this error before you can proceed.
sussy:/srv/www/htdocs/cpanel #
".

Anybody has ever the same problem?

Please tell me what I should do to make my "yum" and "cpanel installer"
can locate my glibc.

Thank you very much in advance.

===
I also did so:
"
sussy:/srv/www/htdocs/cpanel # yum glibc
/usr/lib/yum-plugins/merge-conf.py:22: DeprecationWarning: the md5 module is
deprecated; use hashlib instead
import os, sys, md5
Loaded plugins: aliases, allowdowngrade, basearchonly, changelog, fastestmirror,
: filter-data, list-data, merge-conf, priorities, protect-
: packages, protectbase, refresh-updatesd, skip-broken, tmprepo,
: tsflags, upgrade-helper, verify
Traceback (most recent call last):
File "/usr/bin/yum", line 29, in <module>
yummain.user_main(sys.argv[1:], exit_code=True)
File "yummain.py", line 229, in user_main
errcode = main(args)
File "yummain.py", line 84, in main
base.getOptionsConfig(args)
File "cli.py", line 184, in getOptionsConfig
enabled_plugins=self.optparser._splitArg(opts.enableplugins))
File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 190, in
_getConfig
startupconf.pluginconfpath,disabled_plugins,enabled_plugins)
File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 356, in
doPluginSetup
plugin_types, confpath, disabled_plugins, enabled_plugins)
File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 162, in __init__
self.run('config')
File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 178, in run
func(conduitcls(self, self.base, conf, **kwargs))
File "/usr/lib/yum-plugins/skip-broken.py", line 110, in config_hook
help="skip packages with broken dependencies")
File "/usr/lib/python2.6/optparse.py", line 1014, in add_option
self._check_conflict(option)
File "/usr/lib/python2.6/optparse.py", line 989, in _check_conflict
option)
optparse.OptionConflictError: option --skip-broken: conflicting option
string(s): --skip-broken
sussy:/srv/www/htdocs/cpanel #
".
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages