Mailinglist Archive: opensuse (1596 mails)

< Previous Next >
Re: [opensuse] Bug in xmms2 dependencies - packman (fyi)
  • From: Don Raboud <dwraboud@xxxxxxxxxxxxxxx>
  • Date: Thu, 29 Oct 2009 22:18:24 -0600
  • Message-id: <200910292218.25176.dwraboud@xxxxxxxxxxxxxxx>
On October 29, 2009 09:37:39 pm David C. Rankin wrote:
Attempting to install xmms2, the core part complains that it cannot be
installed because there are no installable providers of libx264.so.60, and
thus the package cannot be installed. The actual conflict file is:

#### YaST2 conflicts list - generated 2009-10-29 22:22:20 ####

nothing provides libx264.so.60 needed by
libavcodec51-0.4.9svn-20080906.pm.0.i586

[ ] do not install xmms2-core-0.4-1.pm.4.i586

< snip >

Checking the system with locate libx264.so.60 reveals:

/usr/lib64/libx264.so.60

< snip >

So first, has anyone else experienced this behavior?

I see exactly the behaviour you describe (I'm using 11.0)

And, second, even if you haven't, any idea why I get an i586 dependency
error on an x86-64 box where the x86-64 shared object file is already
installed?

Not sure, but I notice that (on packman) xmms2 is only available as a i586
package and libx264-60 is only available as a x86_64 package.

I'm not sure how that would be resolved.

--
Don
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
References