Mailinglist Archive: opensuse (1599 mails)

< Previous Next >
Re: [opensuse] NIC installation: What is this error?
  • From: kanenas@xxxxxxxxxxxxx
  • Date: Thu, 8 Oct 2009 08:59:11 -1000
  • Message-id: <200910080859.11746.kanenas@xxxxxxxxxxxxx>
On Thursday 08 October 2009 08:35:03 am Stan Goodman wrote:
At 20:15:49 on Thursday Thursday 08 October 2009, Stan Goodman

<stan.goodman@xxxxxxxxxxxxx> wrote:
At 18:34:56 on Thursday Thursday 08 October 2009, "Ken Schneider -

openSUSE" <suse-list3@xxxxxxxxxxxxx> wrote:
Stan Goodman pecked at the keyboard and wrote:
At 17:53:55 on Thursday Thursday 08 October 2009, Per Jessen

<per@xxxxxxxxxxxx> wrote:
Stan Goodman wrote:
That's true. It doesn't help to choose among the many gcc
compilers on the DVD. Can I assume that gcc-c++ is the way to go?
Or is gcc43-c++ the one with the brass ring? Or gcc43? Or what?

I suspect "zypper in gcc" will get you what you need.

That caused the system to try to access the non-oss repository,
because it complained that it couldn't resolve
download.opensuse.org. The problem is that I am trying to get the
Ethernet card to work, and there is no other way to reach the
outside world. It stands to reason that the necessary compiler has
to be on the DVD. But there are many likely looking gcc compilers
on the DVD; so far I know that gcc43 and gcc43-c++ don't help.
Which one does it want?

Disable all repo's except for the *dvd* or add it if it isn't in the
list, then zypper ref and zypper in gcc.

That made the modules without errors. There are two warning messages
that I assume are expected, indicating that some facility is not
supported by the driver:

r8168_n.c.:526: warning: 'rtl8168_ocp_gphy_read' defined but not used
r8168_n.c.5292: warning: 'rtl8168_reinit_task' defined but not used

The rest of the compilation finished, apparently in good order. <lsmod

| grep r8186> seems to have found the installed driver.

But <ifconfig -a>, according to the instructions, was expected to
include in its response a line about eth0, but there is no such thing
in its two paragraph, which seem otherwise to be in order.

Also worrying is that I now notice in Network Settings/Overview that in
the lower window the name of the Ethernet card is followed by "(no
hwinfo)"

And the upshot is that the network is unreachable.

--
Stan Goodman
Qiryat Tiv'on
Israel

There should be no need to manually install drivers for an rt8168. you might
want to consider removing what you have installed and see where that takes
you. fyi, my vostro shows r8169 as the driver found / installed by yast for
the rt nic. if the card is seen by yast and editing it completes (and the
module is shown / typed in in the hardware tab), then you might want to
verify your cable connection, just as a sanity check.
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >