Mailinglist Archive: opensuse (1473 mails)

< Previous Next >
Re: [opensuse] JRE - how do I get it?
  • From: "David C. Rankin" <drankinatty@xxxxxxxxxxxxxxxxxx>
  • Date: Fri, 26 Jun 2009 08:36:35 -0500
  • Message-id: <200906260836.35800.drankinatty@xxxxxxxxxxxxxxxxxx>
On Sunday 21 June 2009 08:35:18 am Thomas Blasejewicz wrote:

Jerry Houston さんは書きました:
On Sunday 14 June 2009 09:53:16 am James Knott wrote:

How do I get/install JRE and make it operational?

It's available in Yast > Software Management. Just search on "Java" and
you'll see a couple.


Yup. It's the Java Runtime Environment, and they're forever updating it.
An
application designed to work with a newer version will consider an older
version "broken."

Well, that does not seem to everything that is broken.
I start YaST -> Software management (which takes ages! I can go
downstairs and prepare coffee in the meantime)

I still run 10.3 on a number of boxes, even on my desktop at work (It is a damn
good release). Currently the OpenOffice 3.1.0.6 situation is not good on 10.3.
oo3.0.1.3 was OK, but 3.1.0.6 gave me missing toolbar icons, etc. (a bug is
being worked currently)

But to improve the 10.3 YAST SW Mgmt and Update refresh slowness, try this (as
root):

First disable any unneeded repositories (it will decrease refresh
time); then

rm /var/cache/zypp/zypp.db (many times the repository cache will
balloon in size)

This will force a rebuild of your repository cache, and after the first refresh
to rebuild it can cut the refresh time in half. (you would make it to the
coffee maker, but wouldn't have time for it to brew...;-)

Next: Warning. There was an error in the repository initialization ...
Required file is missing: /content
OK
Search for "JRE" -> no results (wonderful)
Search for "JAVA" -> a number.
Check the checkbox next to "Open Office" -> next error: dependency conflict


The packages you want are:

http://download.opensuse.org/distribution/10.3/repo/non-oss/suse/i586/java-1_5_0-sun-1.5.0_update12-23.i586.rpm
http://download.opensuse.org/distribution/10.3/repo/non-oss/suse/i586/java-1_5_0-sun-alsa-1.5.0_update12-23.i586.rpm
http://download.opensuse.org/distribution/10.3/repo/non-oss/suse/i586/java-1_5_0-sun-jdbc-1.5.0_update12-23.i586.rpm
http://download.opensuse.org/distribution/10.3/repo/non-oss/suse/i586/java-1_5_0-sun-plugin-1.5.0_update12-23.i586.rpm

In software management just select "Repositories" as the filter and choose the
"non-oss" repository and check the files;

-or from the command line -

Just do:

rpm -Uvh "list of files above"

-or also from the command line -

zypper in java-1_5_0-sun java-1_5_0-sun-alsa java-1_5_0-sun-jdbc
java-1_5_0-sun-plugin




--
David C. Rankin, J.D.,P.E.
Rankin Law Firm, PLLC
510 Ochiltree Street
Nacogdoches, Texas 75961
Telephone: (936) 715-9333
Facsimile: (936) 715-9339
www.rankinlawfirm.com
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >