Mailinglist Archive: opensuse (1473 mails)

< Previous Next >
Re: [opensuse] UUID=>0x and LVM
  • From: "Boyd Stephen Smith Jr." <bss@xxxxxxxxxxxxxxxxx>
  • Date: Mon, 22 Jun 2009 14:05:20 -0500
  • Message-id: <200906221405.25073.bss@xxxxxxxxxxxxxxxxx>
In <E63AE01D-3B3D-4734-9904-87EA337E99C2@xxxxxxxxxxxxx>, Philip Mötteli
wrote:
Am 19.06.2009 um 18:46 schrieb Boyd Stephen Smith Jr.:
In <7DEBCCBF-A797-45BD-B953-CCD82E03C2CE@xxxxxxxxxxxxx>, Philip
Mötteli wrote:
No sdc appears in '/dev'.

Make sure you have all the modules you need installed.

It has worked for a long time now. So the needed modules have surely
been available. At least, until these problems started.
Apparently my client did some very dirty power offs. Is it possible,
that these destroyed some entire directories on the disk? (This is a
SuSE 9.3 system.)

Are you sure you have the real root file system mounted? This:

.../kernel/drivers
.../kernel/drivers/ata
.../kernel/drivers/usb/core
.../kernel/drivers/usb/host
.../kernel/drivers/firmware
.../kernel/drivers/md
.../kernel/drivers/message
.../kernel/drivers/hid
.../kernel/drivers/input
.../kernel/drivers/acpi
.../kernel/drivers/scsi
.../kernel/fs
.../kernel/fs/jbd
.../kernel/fs/ext3

looks like only the modules that were put into the 'initramfs' created by
'mkinitrd'. It will only have the modules that mkinitrd "thinks" are
required to boot -- it can get that wrong.

You can still get access to file systems on incomplete volume groups as long
as all the LEs in allocated to the LV are located on PVs that LVM can find.
Use partial mode like so:
vgscan -P; vgchange -Pay
Basically, you'll need to add "-P" to every LVM command to work in partial
mode.

If there are some directories missing, I should perhaps install a 9.3
SuSE somewhere and just copy over these directories to the broken
system?

I'm not familiar with SUSE 9.3 (before my time), but I believe rpm is
capable of verifying that all the files in a certain package are correctly
installed.

If partial mode doesn't work for you and since the GParted RescueCD will
boot and find all your filesystems, you could boot from that, then chroot
into your real system and verify stuff using all your expected SUSE 9.3
tools and your existing RPM database.
--
Boyd Stephen Smith Jr. ,= ,-_-. =.
bss@xxxxxxxxxxxxxxxxx ((_/)o o(\_))
ICQ: 514984 YM/AIM: DaTwinkDaddy `-'(. .)`-'
http://iguanasuicide.net/ \_/

< Previous Next >