Mailinglist Archive: opensuse (1473 mails)

< Previous Next >
Re: [opensuse] Java plugin not working in 64-bit Firefox?
  • From: Bob S <911@xxxxxxxxxxx>
  • Date: Wed, 17 Jun 2009 17:35:16 -0400
  • Message-id: <200906171735.16783.911@xxxxxxxxxxx>
On Wednesday 17 June 2009 05:36:22 Michal Vyskocil wrote:
On Wednesday 17 of June 2009 07:38:01 Bob S wrote:
Hello Clayton and others,

Running 11.0 64 bit here, 64 bit Firefox 3.0b5, and KDE3.5. Also having
big problems with Java that I didn't have on 10.3. All exactly the same
except the OS version. I used 1.7 (Iced Tea) and it's plugins there and
it worked perfectly.

icedtea is very experimental and should not be used. After 11.0 was dropped
out from SUSE and it exists just for historical reasons, because it was a
first open source java released by Sun.

Neither 1.6 and it's plugins work, nor 1.7 Iced Tea and it's plugins work
on 11.0.

You must specify if you told about openjdk or sun java, because those
version have different Java plugins. Sun Java should works almost
everywhere.

(Both work fine on Konqueror) In fact when I tried 1.6 and went
to the Java site and clicked on the "Do I have Java" link it actually
killed Firefox. 1.7 survived that but didn't work. Then I tried your
weird combination of 1.6 and the 1.7 plugins. No good.


I also went to the Wiki page suggested by Mariusz and followed the
instructions there step-by-step. Still no good.

Maybe I need to upgrade or downgrade Firefox?

What JVMs do you have installed? rpm -qa | grep java-1_? What do you have
in update-alternatives --display javaplugin?

I suggest remove icedtea and openjdk and use only Sun Java, because it
would works without a problem on openSUSE 11.0.

Hello Michal, Thanks for trying to help

For your info iced tea was the only java Icould get to work on 10.3.
Regardless it does not work on 11.0 and I removed it and put 1.6 back on
before I even wrote the email you replied to. As per your instructions the
following is provided, Keep in mind that Firefox and Java are all x86_64

-----------------------------------------------------------
Easystreet:/ # rpm -qa | grep java-1
java-1_6_0-sun-plugin-1.6.0.u13-0.1
java-1_6_0-sun-1.6.0.u13-0.1
java-1_5_0-gcj-compat-1.5.0.0-65.2

Easystreet:/ # update-alternatives --config libjavaplugin.so.x86_64
No alternatives for libjavaplugin.so.x86_64.

Easystreet:/ # update-alternatives --display javaplugin
javaplugin - status is auto.
link currently points
to /usr/lib64/jvm/java-1.6.0-sun-1.6.0/jre/lib/amd64/libnpjp2.so
/usr/lib64/jvm/java-1.6.0-sun-1.6.0/jre/lib/amd64/libnpjp2.so - priority 1614
Current `best' version
is /usr/lib64/jvm/java-1.6.0-sun-1.6.0/jre/lib/amd64/libnpjp2.so.
--------------------------------------------------------------------------------------
Remember also that any time I try to open a java application in Firefox it
immediately kills Firefox.

Thanks again

Bob S





--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups