Mailinglist Archive: opensuse (1473 mails)

< Previous Next >
[opensuse] UUID=>0x and LVM
  • From: Philip Mötteli <philip.moetteli@xxxxxxxxxxxxx>
  • Date: Sat, 13 Jun 2009 21:35:36 +0200
  • Message-id: <8FC020C1-D875-4DE3-9C4B-2698A393FADC@xxxxxxxxxxxxx>
Hello,


One of my clients has a server, which doesn't boot anymore, because LVM doesn't find one of its hard-drives anymore. It looks for a hard- drive with a specific UUID, but this hard-drive has changed its UUID to 0x.
Fortunately, I think, that I have most of the needed information by LVM, because the first hard-drive of the LVM is working.
I tried everything I found on the net, including rewriting into LVM a new UUID of 0x for this hard-drive. (Though, it rejects a value of 0x.)
Strangely, when I boot into a GParted Live-CD, everything comes up without a hick. I can mount the LVM and access its data.
What does the GParted Live-CD do differently? How could I copy the configuration, GParted Live-CD constructs, over to my real system? (I tried changeroot, copy 'lvm.conf', etc.)


Thanks for any help!

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >