Mailinglist Archive: opensuse (1473 mails)

< Previous Next >
Re: [opensuse] Re: grub no longer being maintained? so Suse drops support for XFS boot?
  • From: Dave Plater <dave.plater@xxxxxxxxxxx>
  • Date: Fri, 12 Jun 2009 09:00:38 +0200
  • Message-id: <4A31FD16.5020809@xxxxxxxxxxx>
Linda Walsh wrote:
Weird. I've been booting from xfs with lilo, and more
recently, 'grub', from suse 7.x up to 11.1.
I haven't any recent probs concerning lilo, but I saw this same
type of issue and a solution in Ubuntu's bug database (though they
encountered this problem 3 years ago and automatically used a
workaround to not corrupt a user's choice of filesystem.

The issue was Grub not being able to write to the root directory
if it is formatted as an XFS partition.
The response was Ubuntu's workaround (maybe openSuSE could figure out
how they did this...it is open source...and they could adopt their
solution rather than just throwing up their hands and saying they
don't support XFS).

The Ubuntu installer automatically uses lilo in the case where the
root (or boot) file system is XFS. Thus no ever sees the problem grub
has with XFS, they simply use the more primitive, but more reliable
'lilo' bootloader.

-linda



I was about to refer you to http://xfs.org/index.php/XFS_FAQ and tell
you to read the lilo and xfs boot sections but I see they have changed
their tune about grub and say that grub now works as of 0.97 so maybe it
will work.
Regards
Dave P
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >