Mailinglist Archive: opensuse (1695 mails)

< Previous Next >
Re: [opensuse] Upgrade to 2.0.0 Hosed VirtualBox
  • From: Wolfgang Rosenauer <wolfgang@xxxxxxxxxxxxx>
  • Date: Wed, 17 Sep 2008 08:37:12 +0200
  • Message-id: <48D0A598.1070303@xxxxxxxxxxxxx>
Eric (openSUSE) schrieb:
Hello All. I've been running the default version of VirtualBox that
came with SuSE 11 up until the other day, when I saw an upgrade was
available. Went ahead and installed it. Guess I shouldnt have.


When I try to start any of my virtual machines, I get this error:
Callee RC: NS_ERROR_FACTORY_NOT_REGISTERED (0x80040154)


I did a little googling, and read that some people had success with
running as root... so I ran virtualbox as root. I get further along,
but I'm still not able to launch any virtual machines. As root,
VirtualBox hangs with "Spawning Session"... 0%... and just stays
there, doesnt ever move. I eventually have to kill it.

That "spawning session" thing usually happens if the vboxdrv kernel
module is not loaded.
Check with lsmod and try to load with rcvboxdrv start which probably
tells you that the kernel module doesn't fit.
Then you can try to recompile it by using "rcvboxdrv setup". (At least
that's how it works with the non-GPL version.

Wolfgang
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References