Mailinglist Archive: opensuse (1606 mails)

< Previous Next >
Re: [opensuse] strange samba rsync problem gets worse
  • From: Damon Register <damonregister@xxxxxxxxxxxxx>
  • Date: Fri, 05 Sep 2008 19:50:56 -0400
  • Message-id: <48C1C5E0.5060608@xxxxxxxxxxxxx>
Brian K. White wrote:
Sounds like you're on track.
I thought I was but it is far from over.

However, I would (I do in fact) just install the prebuilt rsync from
sunfreeware.
I just did. I tried building it from source but that didn't get very
far so I just got the prebuilt packages from SFW. I tested with that
and still get the same old

You said you have solaris 10, I don't remember what platform, so, assuming it's
sparc,
It is an Ultra20 with an AMD64.

for you to install rsync, you could cut & paste this recipe verbtim, paste the
whole block from sfi () { to } right into a telnet/ssh session.
Then run the sfi <pkg> commands manually one at a time, in the order shown.
That's a cool script. Thanks.

If you don't have wget or curl just get the files any way you want of course and
run the gunzip & pkgadd commands manually like the first example.
I had to get those a while ago for some reason I don't remember any more.

So far everything I tried gives me the same error.

rsync: The server is configured to refuse --iconv
rsync error: requested action not supported (code 4) at clientserver.c(840)
[receiver=3.0.3]
rsync: connection unexpectedly closed (5 bytes received so far) [sender]
_exit_cleanup(code=12, file=io.c, line=635): entered
rsync error: error in rsync protocol data stream (code 12) at io.c(635)
[sender=3.0.3]
_exit_cleanup(code=12, file=io.c, line=635): about to call exit(12)


No matter what options I try, I still get the "refuse --iconv" message.
I got the impression from the man page that if I didn't specify a charset
that the iconv would be refused unless I added no-iconv to the refuse options.

Since I wasn't getting anywhere with the Solaris setup, I installed SuSE 11
on an old spare PC. After getting the rsync daemon setup there, I tried
it and got the same message. It seems that the rsync daemon on the SuSE
system has the same problem. So, since the SuSE setup has the same problem
I will focus on that first since I might have a better chance of getting
help. Perhaps if I get the SuSE one working, I will have found the solution
for the Solaris one as well.

Can anyone help with rsync on SuSE?

Damon Register
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups