Mailinglist Archive: opensuse (3319 mails)

< Previous Next >
Re: [opensuse] Getting SSH to Work
  • From: Rick Bilonick <rab@xxxxxxxxxxxx>
  • Date: Sat, 07 Jun 2008 02:31:16 -0400
  • Message-id: <1212820276.3271.12.camel@xxxxxxxxxxxxxxxxxxxxx>

On Fri, 2008-06-06 at 11:37 -0700, John Andersen wrote:
On Fri, Jun 6, 2008 at 7:37 AM, Rick Bilonick <rab@xxxxxxxxxxxx> wrote:

On Fri, 2008-06-06 at 10:05 -0400, james Wright wrote:
On Fri, Jun 6, 2008 at 1:42 AM, Rick Bilonick <rab@xxxxxxxxxxxx> wrote:
OK, I downloaded SLED SP2 (as suggested by someone on this list) and
updated the HP 2133. This of course wiped out my wireless (apparently
HP/Novell are using a kernel module that you can see in SP2 but cannot
install) but I was able to install ndiswrapper and get the wireless
back.

I tried ssh and it worked right away. So I'm making a good bit of
progress. Thanks to every one who responded.

Rick B.

Out of curiosity, can you now edit ssh_config and sshd_config as root?

I could get in before, but not through the shell using vi or cat, only
using nautilus launched from a root shell. Now with SP2, I can view it
from a shell window even as a user.

That's just wrong.

Not being able to get there in a shell (without SP2) speaks to some
horrible borken stuff.


Do/Did you have SELinux options installed or something?




I don't believe selinux was installed when I had SLED SP1 installed. HP
is sending me a rescue disk which is SP1 (HP is not shipping SP2 with HP
2133's yet). Regardless, it all works fine with SP2 with the exception
that it screwed up my wireless. The bcm4312 worked fine in SP1 - I could
contact WEP and WPA systems very easily. Apparently there is some
proprietary Broadcom kernel module. I can see it in the SP2 DVD using
Yast but it won't let me install it or if it is installed it's not
working under SP2. I can't tell - it has a strange name and I can't find
it using "rpm -qv". Although the hardware listing seems to indicate that
there was no driver installed for the 4312. I installed ndiswrapper
which works OK except for wpa (it never connects). Not sure why updating
from SP1 to SP2 would hose the wireless module.

Apparently, when I called HP tech services, I was the first one to have
updated from SP1 to SP2. (They have 5 or 6 people dedicated to Linux, at
least for the HP 2133 mini-notebook.)

I'm not sure if I'm going to go to the trouble of installing SP1 from
the rescue disk. SP1 is not very functional except for the wireless. I
have an extra 160gb hard drive that I'm going to install and try
installing openSuse 11 and/or Fedora 9.

Rick B.

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >