Mailinglist Archive: opensuse (2778 mails)

< Previous Next >
Re: [opensuse] Bad Magic
  • From: "Dominique Leuenberger" <Dominique.Leuenberger@xxxxxxxxxxxxx>
  • Date: Thu, 29 May 2008 11:19:36 +0200
  • Message-id: <483E9F58.2554.0029.1@xxxxxxxxxxxxx>
On 28.05.2008 at 22:41, "Carlos E. R." <robin.listas@xxxxxxxxxxxxxx> wrote:
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1



The Wednesday 2008-05-28 at 10:48 -0700, Kai Ponte wrote:

I don't have any factory sources set. In the YaST community repositories I
have checked only

Main Repository (NON-OSS)
Main Repositor (OSS)
Main Update Repository
NVIDIA Repository
Packman Repository
VideoLan Repository

Here's teh full error message I got this morning.

Installation of [S3:1][package]libvorbis-1.2.0-50.i586 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error:
unpacking of archive failed: cpio: Bad magic (with --nodeps --force) Error
Installation of [S3:1][package]libvorbis-devel-1.2.0-50.i586 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error:
unpacking of archive failed: cpio: Bad magic (with --nodeps --force) Error

A wild guess:

Opensuse 10.3 has libvorbis-1.2.0-11, and factory has libvorbis-1.2.0-48
or later, so you are not installing a plain suse 10.3 package. As it
appears you don't have a factory repo, then one of the extra repos
(videolan, packman) is making rpms for 10.3 inapropiate for 10.3. You
should ask them, but I don't know how.


VideoLAN repository does not provide any base libraries that are maintained in
the Distributions.

if i would come from packman, you would see a version-release, where release
always containst .pm somewhere, so they are easily spottable.

Dominique

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups