Mailinglist Archive: opensuse (2348 mails)

< Previous Next >
Re: [opensuse] Re:Boot failure
  • From: "David C. Rankin" <drankinatty@xxxxxxxxxxxxxxxxxx>
  • Date: Fri, 04 Apr 2008 10:45:54 -0500
  • Message-id: <47F64D32.6060003@xxxxxxxxxxxxxxxxxx>
Andy Krynicki wrote:
Hi All
I need some help with Suse10.3. Recently I purchased some pc's, one with an
ASUS P5L-MX and the other with a FOXCONN 945G7AD motherboard installed. I
attempted to install Suse and it installed fine, until the re-boot stage
when it put a message to screen saying booting from local disk and stopped.

The hard disks where SATA in both, so in one machine I replaced them with an
adeptec scsi controller and tried again with the same result.

Windows xp loads fine and boots no problem. The things these two boards have
in common is the Intel 945G northbridge and ICH7 Southbridge. Both boards
load ata_piix as the driver module. I suspect this is where the problem lies
but am no expert. I have been on this for day's now and still no nearer
finding a solution, so any help would be gratefully received.
Thanks in advance
Andy.


Andy,

Did you check the md5sum on the install media? I have seen the problem you describe occur when there is a problem with the 10.3 disk itself. If you have an iso image that the md5sums check out on, then try burning it again at a (s.l.o.w.e.r) speed. Second, if you have the iso on a computer you can export it nfs or offer it ftp, don't even bother burning a dvd, just do a network install.

Second, I have also seen installs on perfectly good disks stop right after all the software is installed but before the system is started for the "set root password" part of the install routine. Two problems generally (1) the GRUB boot loader wasn't written to disk and now you can't boot, or two, the install just fails to pick back up. In both cases you are left with a system that has all the software installed, but can't boot and doesn't have all of the hardware configured.

A couple of possibilities. (going from memory) **Note, the repair install is broken on the original 10.3 install DVD. (1) Boot from the DVD, live CD, etc and then "boot installed system". If you can minimally boot the system, you should be able to start yast from the command line or at least install grub from the command line using "grub-install /dev/sda" (usually). If you are able to do this, then after you mount the / partition you can:

touch /var/lib/YaST2/runme_at_boot (thanks Anders)

reboot and have yast pick up the install at that point.

Your problem isn't a motherboard problem. The first 2 out of 3 10.3 installs I did on 10/4/07 acted the same way on MSI and Gigabyte boards. (Funny, if I recall correctly, the only install that actually completed the first day 10.3 was released was on a Dell -- what are the odds)

Good luck.

--
David C. Rankin, J.D., P.E.
Rankin Law Firm, PLLC
510 Ochiltree Street
Nacogdoches, Texas 75961
Telephone: (936) 715-9333
Facsimile: (936) 715-9339
www.rankinlawfirm.com
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
References