Mailinglist Archive: opensuse (2348 mails)

< Previous Next >
Re: [opensuse] Zypper Dup Failed : unpacking of archive failed: cpio: Bad magic
  • From: Russ Fineman <russbucket@xxxxxxx>
  • Date: Thu, 3 Apr 2008 07:47:42 -0700
  • Message-id: <200804030747.42344.russbucket@xxxxxxx>
On Thursday 03 April 2008 01:40:08 am Dave Plater wrote:
Masim "Vavai" Sugianto wrote:
Hi,

I tried to upgrade my openSUSE 10.3 into 11.0 factory but it seems to
stop in the first step.

In order to install this package, you must agree to terms of the above
license. Continue? [yes/NO]: y
Downloading package man-pages-2.68-23.noarch, 4.1 M (3.8 M unpacked)
* Downloading: man-pages-2.68-23.noarch.rpm [done (4.9 K/s)]
* Installing: man-pages-2.68-23
Installation of man-pages-2.68-23 failed:
(with --nodeps --force) Error: Subprocess failed. Error: RPM failed:
error: unpacking of archive failed: cpio: Bad magic

I found the suggestion here :
http://www.suseforums.net/index.php?showtopic=48136&pid=237513&mode=threa
ded&show=&st=0&#entry237513 but I don't know how to updated the rpm and
rpmdelta packages via YaSTs Software Management because the preparation
of upgrade has removed yast (typing yast and yast2 produce "command not
found")

You need to upgrade to factory rpm-4.4.2-182.i586.rpm or above.
zypper in rpm before the zypper dup. I've filed a bug report already
about incorrect dependencies. They have changed the rpm compression format.
Dave

I did this yesterday after getting the advise to use zypper. Everything
worked fine after that.
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >