Mailinglist Archive: opensuse (2348 mails)

< Previous Next >
Re: [opensuse] KRFB fails handling RDP connections
  • From: "Jason Bailey, Sun Advocate Webmaster" <webmaster@xxxxxxxxx>
  • Date: Tue, 01 Apr 2008 22:00:01 -0600
  • Message-id: <47F304C1.9020903@xxxxxxxxx>
On Tuesday 01 April 2008 08:08:12 pm Jason Bailey, Sun Advocate Webmaster wrote:
This is a weird one...

I have two workstations running openSUSE 10.3 (x86_64). I have added a
few repositories (i.e. Packman) but nothing unusual or out of the
ordinary. Both are x86_64 - one is a laptop (Core 2 Duo) and one is a
desktop (EM64T single core).

Suddenly, KRDC won't do RDP connections (on either). I didn't change
anything (at least I don't remember changing anything). It'll do VNC
just fine. The RDP gets past the preferences setting and then just hangs
(just before the actual screen opens).

Now, what's funny is that I can "rdesktop hostname" and it works fine. I
just can't get to it via KRDC.

What really sucks is that I use the KIO slave from the "run" box... so
it's been an adjustment to do this the other way.

I've reloaded the RPM containing krdc, but to no avail.


rpm -qa | grep krdc

ALso any error that you are getting. Is krdc crashing? Can you run from command line and see what happens when it fails.
also output of:
rpm -qa | grep qt

THanks



No, krdc never crashes. It gives me the address box. I type "rdp://hostname". I click OK. I get the preferences window. I click connect, and then it just sits there, "establishing connection..."

Running from command line:
*** WARNING *** The programme 'krdc' uses the Apple Bonjour compatiblity layer of Avahi.
*** WARNING *** Please fix your application to use the native API of Avahi!
*** WARNING *** For more information see <http://0pointer.de/avahi-compat?s=libdns_sd&e=krdc>
current depth: 0
Color depth: 8

It just sits there forever until I xkill it.

Interestingly, 'rpm -qa | grep krdc' gives me nothing. But I can obviously run krdc. It's there. I can run rdesktop, as I said, with no problems.

rpm -qa | grep qt gives me this:
qt3-3.3.8-76.2
qt3-devel-doc-3.3.8-76
yast2-qt-2.15.16-19
libqt4-x11-4.3.1-23.4
avahi-qt3-0.6.20-40
qtcurve-gtk2-32bit-0.52.3-31
libqt4-dbus-1-4.3.1-23.4
dbus-1-qt3-devel-0.62-110.1
pinentry-qt-0.7.2-1
qt3-devel-tools-3.3.8-76
libqt4-4.3.1-23.4
dbus-1-qt3-32bit-0.62-110.1
libqtpod-0.3-86
qtemu-1.0.4-2.3
poppler-qt-0.5.4-101.2
qtcurve-gtk2-0.55.0-3.2
qt3-devel-3.3.8-76.2
libqt4-sql-mysql-4.3.2-6.1
qt3-32bit-3.3.8-76.2
qtcurve-kde-0.55.2-3.6
yast2-control-center-qt-2.15.4-12
libqt4-qt3support-4.3.1-23.4
dbus-1-qt3-0.62-110.1
python-qt-3.17.3-18
libqt4-sql-4.3.1-23.4
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >