Mailinglist Archive: opensuse (2459 mails)

< Previous Next >
[opensuse] Sendmail help
  • From: Mike Grau <m.grau@xxxxxxxxxxxxxxx>
  • Date: Wed, 26 Mar 2008 11:51:39 -0500
  • Message-id: <47EA7F1B.3050400@xxxxxxxxxxxxxxx>
Hello,

This is the second time I've posted this message; the first time it never showed up ...

I have the following machines with sendmail built from tarballs
compiled and working beautifully:

SuSE Linux 9.0 (i586)
Linux 2.4.21-303-smp4G SuSE Linux 9.0 (i586).
sendmail-8.13.6 built from tarball

SUSE LINUX 10.0 (i586)
Linux a004099 2.6.13-15.8-smp #1 SMP Tue i686 i386 GNU/Linux
sendmail-8.13.6 built from tarball

openSUSE 10.3 (i586) - Kernel \r (\l).
Linux volga 2.6.22.13-0.3-default #1 SMP i686 i386 GNU/Linux
sendmail-8.14.2 built from tarball

All these use virtually the same site.config.m4


However on a x86-64 machine running 10.2 ...

openSUSE 10.2 (X86-64) - Kernel \r (\l).
Linux 2.6.18.8-0.8-default #1 SMP x86_64 x86_64 x86_64 GNU/Linux

having tried:
sendmail-8.13.6 built from tarball
sendmail-8.14.1 built from tarball
sendmail-8.14.2 built from tarball

Sendmail builds and works with the exception that it does not log
the hostname of the connecting relay, but only gives the bracketed
ip address - [65.54.246.143] instead of, say,
bay0-omc2-s7.bay0.hotmail.com -
and the hostname is not provided to milters - also just the bracketed ip
address.

sendmail[2546]: m2LJVpYZ002546: from=<xxxxxx@xxxxxxxxxxx>, size=6972520,
class=0, nrcpts=1, msgid=<BAY140-W316D9F76FFAB662746FD0EE3010@xxxxxxx>,
proto=ESMTP, daemon=MTA, relay=[65.54.246.143] <<<

It does, however, put the hostname in the Received header that it adds.
Example:
Received: from lists4.suse.de ([195.135.221.135])

Bind is running locally and DNS seems to work as sendmail rejects
non-existant domains and TEMPFAILs those that it cannot resolve the PTR
record.

Also if I put an entry in /etc/hosts, that hostname is logged and
provided to milters, so I assume it must be DNS related

I've googled but can find anything - Woe is me!

Can somebody tell me what the problem might be?

sendmail Version 8.14.2
Compiled with: DNSMAP LOG MAP_REGEX MATCHGECOS MILTER MIME7TO8 MIME8TO7
NAMED_BIND NETINET NETUNIX NEWDB PIPELINING SCANF USERDB
XDEBUG

Here are some perhaps relevant ? rpms installed:

glibc-2.5-34.7
glibc-devel-2.5-34.7
glibc-i18ndata-2.5-34.7
glibc-locale-32bit-2.5-34.7
glibc-32bit-2.5-34.7
glibc-devel-32bit-2.5-34.7
glibc-locale-2.5-34.7
bind-9.3.2-56.5
bind-libs-9.3.2-56.5
bind-utils-9.3.2-56.5
bind-libs-32bit-9.3.2-56.5
bind-devel-9.3.2-56.5
bind-chrootenv-9.3.2-56.5

Thanks for any clue!
-- Mike

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >