Mailinglist Archive: opensuse (2459 mails)

< Previous Next >
Re: [opensuse] Big time frustration plus re 10.3's zyppo (otherwise known as zypper)
  • From: Basil Chupin <blchupin@xxxxxxxxxx>
  • Date: Mon, 24 Mar 2008 14:15:32 +1100
  • Message-id: <47E71CD4.6050605@xxxxxxxxxx>
Default Account wrote:
Basil Chupin wrote:
On a second set of HDs I have 10.3 installed - and installed as a simple newbie would install a copy of GM copy of 10.3 and without knowing anything about smart and whatever.

I haven't booted this copy of 10.3 for some time (weeks) but decided that I would so a short while ago to try and see (1) what my friend, whom I am trying to convert to openSUSE 10.3 is seeing things, and (2) to try out for myself some of the new features like KDE 4.

Well, what a damn disaster when zypper checked for new uprgrades/security upgrades!

zypper showed that there were some 72+ files to be upgraded but when I let it loose to do this I got the following:

QUOTE

2 Problems: Problem: No valid solution found with just resolvables of best architecture. Problem: Cannot install kaffeine-lang Problem: No valid solution found with just resolvables of best architecture. With this run only resolvables with the best architecture have been regarded. Regarding all possible resolvables takes time, but can come to a valid result. Solution 1: Make a solver run with ALL possibilities. Regarding all resolvables with a compatible architecture.

UNQUOTE

But this was only after I wiped a few Repositories from the Repositories List.

Now, what the heck does the goobdle-dook in the above error message mean?!

What does, "Make a solver run with ALL possibilities. Regarding all resolvables with a compatible architecture."?

What the heck is "a solver"?!

I have added/removed repositories from the list without any change.

I am trying to convert a friend to openSUSE and I am afraid that he may face be facing the same message if I tell him to how to upgrade his just-installed openSUSE using zypper.

Question now is: how do I deleted whatever database of RPMs I have so that zypper can stop acting like a drunken sailor and upgrade the OS without problems?

Ciao.


Basil I think I may have the answer for you. however all the following situations need to be present first for the solution to work.

1. You are installing X_64 GM 10.3
2. Your PC has an X_64 processor
3. You are installing a KDE desktop
A.. You have probably elected to install Acroread OR Linux form of Adobe reader. ALL you need to do is unselect acroread and all should be o.k

Let me know

Scott


Thanks for the response but, except for the last criterion, none of the above apply. Furthermore, I am not trying to install 10.3 - it's already installed, I was simply allowing zypper to do the upgrades/updates after a few weeks of 10.3 not being booted. Also, Acroread is already installed and has been for some weeks.

Ciao.


--
If you really want to know, you won't ask me.


--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >