Mailinglist Archive: opensuse (2459 mails)

< Previous Next >
Re: [opensuse] Corrupted yast repository db
  • From: "Anton Moiseev" <benderamp@xxxxxxxxx>
  • Date: Fri, 21 Mar 2008 12:10:17 +0300
  • Message-id: <9aa228cf0803210210i3c23a8a2m73350a16db77b401@xxxxxxxxxxxxxx>
On Fri, Mar 21, 2008 at 10:05 AM, <kanenas@xxxxxxxxxxxxx> wrote:

On Thursday 20 March 2008 08:37:07 pm Hylton Conacher (ZR1HPC) wrote:
Rajko M. wrote:
On Saturday 15 March 2008 10:41:17 am Anton Moiseev wrote:
How can I repair this? I also agree to remove the whole repository
database to add all repositories manually again.

Delete:
/var/cache/zypp/zypp.db
and start YaST Software Management or run 'zypper ref'

Could Anton merely have run, from a root console:

rpm rebuilddb

Wondering what alerted you to the fact that zypper was in use?

Just wondering

Hylton

rpm --rebuild db did *not* clean up my system. Yast was showing 3 firefoxes
installed, any effort to remove them resulted in error messages, the dirs
were empty ( they wer not emptied manually by me), the db is still running
corrupt in my system and now i am running ff-3 from my home dir. It is a good
thing that ff does not really *install* anything, otherwise i would probable
have real trouble.
Any more drastic ways to rebuild the db? i even temporarily moved all the db
related files out of /var/lib/rpm and tried rebuilddb again, that did not
work either.
d.




In my case "deleting /var/cache/zypp/zypp.db" saved the situation - I
have posted reply on this, but it has gone personally to Rajko - I
have forgotten to change the "To" field to "opensuse@xxxxxxxxxxxx"
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups