Mailinglist Archive: opensuse (2459 mails)

< Previous Next >
Re: [opensuse] bizarre problem with pdflatex
  • From: auxsvr@xxxxxxxxx
  • Date: Thu, 20 Mar 2008 20:01:28 +0200
  • Message-id: <200803202001.29276.auxsvr@xxxxxxxxx>
On Thursday 20 March 2008, Dirk Petry wrote:
Hi,
I am using pdflatex under opensuse 10.3 without any modifications.
I have two computers with what I thought was exactly the same
installation. I also copied my entire home directory one to one from
the first to the second computer.
On the first computer the processing of my relatively simple
myfile.tex file works without problems. But on the second computer I get

the following error message:
> pdflatex myfile.tex

This is pdfTeX, Version 3.141592-1.40.3 (Web2C 7.5.6)
entering extended mode
(./myfile.tex
LaTeX2e <2005/12/01>
Babel <v3.8h> and hyphenation patterns for english, usenglishmax,
dumylang, noh
yphenation, basque, bulgarian, coptic, welsh, czech, slovak, german,
ngerman, d
anish, esperanto, spanish, catalan, galician, estonian, finnish, french,
greek,
monogreek, ancientgreek, croatian, hungarian, interlingua, ibycus,
indonesian,
icelandic, italian, latin, mongolian, dutch, norsk, polish,
portuguese, pinyin
, romanian, russian, slovenian, uppersorbian, serbian, swedish, turkish,
ukengl
ish, ukrainian, loaded.
(./myarticle.cls

LaTeX Warning: You have requested document class `myarticle',
but the document class provides `article'.

Document Class: article 2000/05/19 v1.4b Standard LaTeX document class
(/usr/share/texmf/tex/latex/base/size12.clo))

! LaTeX Error: File `html.sty' not found.

Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: sty)

---8<---
I.e. pdflatex claims it can't find the file html.sty even though
this file actually exists in the default location.
It is in /usr/share/texmf/tex/latex/html/html.sty .
As it is on the machine where everything is working.

I tried to reinstall everything from the default repositories.
I tried to compare the contents of the relevant directories on the
two computers. I tried to compare the settings of the environment
variables and the output of texconfig.
I can't find any difference between the two installations.
And the input files are identical.

I suspect some setup file is not correctly written.
But which one?
And how can this be if I installed everything as it
came from the repository on both machines without ever
making any modifications myself?

Please help!

Thanks in advance.

Dirk

Try texhash as root. I have reported a similar bug with some texlive packages,
maybe this is the same.
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References