Mailinglist Archive: opensuse (2459 mails)

< Previous Next >
Re: [opensuse] / as a LV
  • From: LDB <thesource@xxxxxxxxxxx>
  • Date: Tue, 18 Mar 2008 21:35:19 -0400
  • Message-id: <47E06DD7.6090503@xxxxxxxxxxxxxxxxxx>
Anders Johansson wrote:
LDB wrote:
I had exactly the same problem - root cause was that Grub did not get
installed to the MBR of /dev/cciss/c0d0. Fix was to boot into rescue
mode, mount the root (/dev/system ... however your LVs are setup). Then mount /dev and /proc into the newly mounted root, chroot to the
/dev/system/... root, and then re-run grub install to install into the
MBR of /dev/cciss/c0d0.
Worked like a charm here, hope it works for you as well.


Thank you Moby .. Great fix .. now I just have to figure out how to get
it automated. :)

Are you saying you tested it and it worked?

I don't see how it could possibly be the problem. Your machine booted,
so grub must be there

I think Pete Connolly's advise about using mkinitrd -f lvm2 is more
likely to work.

But you may have run into a bug in the SP1 mkinitrd. I suggest you boot
the system using the installer's "boot installed system" and run an
online update to get the latest fixes

You might also consider opening a call with novell support, so it can be
properly investigated, if none of the ideas in this thread work

Anders

No the grub-install did not work for the reasons you specified.

Yep, I was told in the opensuse-autoinstall list that there is a bug
with mkinitrd.

Good suggestion Anders ..

Thanks,

LDB
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >