Mailinglist Archive: opensuse (2459 mails)

< Previous Next >
Re: [opensuse] Permission problem while accessing a folder mounted with CIFS
  • From: Alexander Winizki <awinizki@xxxxxx>
  • Date: Mon, 17 Mar 2008 22:15:15 +0100
  • Message-id: <47DEDF63.5050804@xxxxxx>
John Andersen schrieb:
On Mon, Mar 17, 2008 at 1:44 PM, Alexander Winizki <awinizki@xxxxxx> wrote:

I have already worked through the mount.cifs man page trying out all the
options - no use. My last attempt was:
bigblue:/ # mount -t cifs //dreambox/harddisk /mnt/dreambox --verbose -o

user=root,password=******,noperm,domain=minander,uid=0,gid=0,file_mode=0777,dir_mode=0777,noacl,rw

Uid=0,GID=0 ?????

That seems odd, have you experimented with that?
yes, I have also tries uid=root,gid=root

Another thing that I have noticed is that specifying a wrong password
does not produce an error message -

Well thats what you get with security=share and a wide open guest account.

That old version of samba may be confused by cifs. Did I miss a post in
this thread where you indicated smbmount worked or not?

The following things work: mounting from a Windows XP machine, creating a "network folder"
in KDE (which is not visible to non-KDE programs) and smbclient. I could not find, smbmount in
OpenSuse 10.3 repositories and I also have read that on some other current distros there is an smbmount command
which is simply redirected to mount.cifs. the "real" smbmount is said to be deprecated according to what I have found
on the web and I dont know how to install it or whether it will conflict with the other parts of the samba suite.
Btw., I have also tried out fusesmb, but it seems just to do nothing. Anybody familiar with that?

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >