Mailinglist Archive: opensuse (2459 mails)

< Previous Next >
[opensuse] RESEND: ide-generic not included in initrd (10.3)
  • From: Standard SG <standard_sg@xxxxxxxxx>
  • Date: Mon, 10 Mar 2008 18:45:07 -0700 (PDT)
  • Message-id: <760686.63008.qm@xxxxxxxxxxxxxxxxxxxxxxxxxxx>
This is a resend. Nobody answered me the first time
around.

=====

This question is possibly in reference to the bug
listed at

https://bugzilla.novell.com/show_bug.cgi?id=135612

Also, is closely related to the thread referenced by

http://lists.opensuse.org/opensuse/2006-02/msg01111.html

I've tried installing openSUSE 10.3 on a couple of
different Pentium 3 machines. Rather than using a
standard hard drive, I'm using a CompactFlash (CF)
card with a CF to IDE adapter. That aspect may be
irrelevant, but I've included it anyways.

During the initial install, it was unable to find any
of the IDE devices (CF or CDROM). I was using the mini
CD for installing over the network where I had the DVD
ISO mounted on another machine running a web server.

To get the installer to properly detect my IDE
devices, I had to include the following boot options
prior to the installation:

brokenmodules=ata_piix,piix insmod=ide-generic

Once I did this, it detected my devices and everything
installed without any problems. But once it rebooted
the machine to boot from the hard drive (CF card) for
the first time, it was unable to detect any IDE
devices once again, where it stops at 'Waiting for
device xxx to appear..'. This was confusing since
'insmod=ide-generic' was automatically included in my
initrd line in GRUB.

After numerous installs with different options, I
finally realized that the ide-generic module was not
built into the installed initrd, as mentioned in the
thread referenced earlier, so it actually was not
getting loaded at all.

I was able to fix this by booting the install CD with
the same options I used during the install, and then
selecting boot an installed system and selecting the
root partition. This way it loaded the installer's
initrd first with the proper modules. Once it booted,
I modified /etc/sysconfig/kernel and added
'ide-generic' to INITRD_MODULES. I ran mkinitrd and
rebooted, and then it found my IDE devices and
everything was fine. I verified that the
ide-generic.ko module is in this initrd image, while
it was not there in the originally installed initrd.

It seems like this was an old problem that never
really got corrected. Basically, I would expect that
if I specified insmod=ide-generic as a boot option
during the install, it should include that option in
the boot loader (which it did), but it should also
automatically include that module in the initrd image
(which it didn't). This expectation should be
regardless of what hardware I'm using; if I explicitly
specify it, it should automatically include it. It did
properly exclude the modules I specified with the
brokenmodules, so why didn't it include the modules I
specified with insmod?

I'm not sure if this is considered a bug, but if it
was never fixed before, I would assume that's it's
still a problem in the 10.x line. If it is a bug, I
would want to create another one rather than re-open
the previous one, since it should be considered a
hardware independent problem.

SG



____________________________________________________________________________________
Looking for last minute shopping deals?
Find them fast with Yahoo! Search.
http://tools.search.yahoo.com/newsearch/category.php?category=shopping
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups