Mailinglist Archive: opensuse (2459 mails)

< Previous Next >
Re: [opensuse] Opensuse Updater endless Loop - Bad Cups Update?
  • From: Marcus Meissner <meissner@xxxxxxx>
  • Date: Thu, 6 Mar 2008 13:36:10 +0100
  • Message-id: <20080306123609.GC5467@xxxxxxx>
On Wed, Mar 05, 2008 at 11:46:57AM -0800, John Andersen wrote:
Today Opensuse Updater indicated there was new fixes (security fixes
for CUPS etc).

I told the updater to install these, and they all went fine, but then
the updater turns
ORANGE and says there is one more recommended upgrade. The additional
recommended
upgrade is for Cups, Gnome Collection of updates version 4996-0.

I don't even have Gmone installed !?!??

Regardless of whether I cancel or go ahead and tell it to install
(which probably fails
because I don't have gnome installed), the updater prompts again for
the same package.

Whats up with this package, and why does updater continually prompt for
packages
I have rejected?

If the update can't install for dependency reasons (I don't have
Gmome, remember?) then
why does the Updater not just TELL ME THIS?

Thanks to all the reporters.

The issue was a low level problem caused by us releasing two
patches labeled "cups" yesterday, patch-cups-4996 containing the cups+GNOME
fixes, and patch-cups-50something, containing CUPS security fixes.

The Updater Systray Applets were not able to handle this situation
correctly, and tried to install the new "cups" patch always, but still seeing
the old one uninstalled.

This was the cause of the "icon being orange", but no reported errors.

We have meanwhile renamed the cups+GNOME bugfix patch to
"patch-gnomefixes-4996",
so it will no longer conflict with the security cups one.

Ciao, Marcus
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
References