Mailinglist Archive: opensuse (2634 mails)

< Previous Next >
Re: [opensuse] Re: [Powerline networking - WAS: local network/ADSL router not available after boot - manual reconfiguration needed]
  • From: Peter Breger <peter.breger@xxxxxxxxx>
  • Date: Thu, 01 Mar 2007 22:01:04 +0100
  • Message-id: <45E73F10.7070100@xxxxxxxxx>
Peter Breger wrote:
Rajko M. wrote:
On Sunday 18 February 2007 09:09, Peter Breger wrote:

but the router is correctly keeping all other PCs happy on the network,
...
It is the boot process on the Linux that is
at fault, being the only process which is not successful. Manual YaST
setup succeeds. (Same as simultaneous use on other computers running
windows does not show any problems at all).

Hi Peter,

Have you tried to setup static address for your connection? This will either solve your problem or make possible to cut and paste text direct from Linux box to continue DHCP troubleshooting :-)

You need some local address that is not used by router as DHCP range. By now all routers, that I have configured, don't use range between 192.168.x.201 and 192.168.x.254. The default route is your router 192.168.1.1 (I guess).
etc etc

Thanks Rajko! I am afraid that did not do it either. In fact I had tried it before, but with your suggested IP range, I had another go at it.

The assignment of IP address worked, however the Ping 192.168.1.1 then resulted in Destination Host unreachable. Had to first go through a full cycle with YaST : deleting card configuration ... then entering YaST again editing card configuration with static address --- voila it works while in the session -- BUT NOT AFTER REBOOT! So the behaviour is the same as with DHCP.

It is possible to delete Network card configuration, then in a new YaST run edit it to connect successfully. But never on reboot (of course I use ON CABLE CONNECT in YasT for manual start of connection and ON BOOT for preparing a rebooting.

Another snippet - after rebooting, the card has no IP address (previously set static 192.168.1.202). I then use ifconfig eth0 down. THEN type ifconfig eth0 192.168.1.202. THEN ifconfig eth0 up -- it works again. But not after reboot.

What is it that is missing in the boot sequence???

Regards, Peter


Had another go at things - installed Suse 10.2 after speaking to Suse people at FOSDEM - no luck!

Already in text mode level 3, I cannot succeed to get to the network.
rcnetwork restart does not help either

Although it seems illogical since it can be got to work manually (no longer in suse 10.2 yet), I am using a ethernet cable to a powerline plug -- anybody with experience if this use of a powerline network needs another setup item? Router and windows pcs do not sem to care about teh powerline conversion inbetween, since the output from pc or router is simply ethernet cable.

Forever hopeful,
Peter

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups