Mailinglist Archive: opensuse (2224 mails)

< Previous Next >
Re: [opensuse] LILO/Grub Problem
  • From: Bob S <usr@xxxxxxxxxxx>
  • Date: Tue, 6 Feb 2007 23:55:18 -0500
  • Message-id: <200702062355.18158.usr@xxxxxxxxxxx>
On Tuesday 06 February 2007 17:38, Joe Morris (NTM) wrote:
> Bruce Marshall wrote:
> > Just a thought here.... Since it didn't show up, it makes me think
> > he's adding it to the wrong menu.lst file. He has 10.0 and 10.2
> > each with their own /boot/grub/menu.lst I would assume. Perhaps he's
> > dealing with the wrong one?
>
> No, the 10.0 used lilo.
>
> > Since he installed 10.2, I would assume that the MBR is pointing to the
> > 10.2 /boot/grub
> >
> > I've never heard of a menu item not showing up without some error being
> > shown.
>
> Same here. Since he used to use lilo, his 10.2 should be the only grub
> and menu.lst. And I agree, I don't understand how it doesn't even show
> up either.
>
OK Gentlemen,

Stick with me .....Please???

I checked Yast - Bootloader and 10.0 was there. But there was practically
nothing describing/pertaining to it. No /dev/root - no nothing. So I edited
the file extensively and saved it.

Rebooted, and 10.0 showed up in the boot menu. Some success I guess. But now
it fails with an Error 15 File not found. Grrrr......Did some Googling on
the grub error 15 but didn't find anything that I thought would pertain to
this.

Here is the present version of my menu.1st:
-------------------------------------------------------------
# Modified by YaST2. Last modification on Tue Feb 6 22:12:27 EST 2007
default 4
timeout 15
gfxmenu (hd2,0)/boot/message

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.2
root (hd2,0)
kernel /boot/vmlinuz-2.6.18.2-34-default root=/dev/sda1 vga=0x31a
resume=/dev/sda2 splash=silent showopts
initrd /boot/initrd-2.6.18.2-34-default

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
rootnoverify (hd0,0)
chainloader (hd0,0)+1

###Don't change this comment - YaST2 identifier: Original name: floppy###
title Floppy
rootnoverify (hd0,0)
chainloader (fd0)+1

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 10.2
root (hd2,0)
kernel /boot/vmlinuz-2.6.18.2-34-default root=/dev/sda1 vga=normal
showopts ide=nodma apm=off acpi=off noresume edd=off 3
initrd /boot/initrd-2.6.18.2-34-default

### Added 10.0 Boot ###
title openSUSE 10.0
root (hd1,0)
kernel /boot/vmlinuz-2.6-15.13-default root=/dev/hdb1 vga=0x31a
resume=/dev/hdb2 splash=silent showopts
initrd /boot/initrd-2.6-15.13-default
--------------------------------------------------------------------------------------------
It does wrap in this outgoing e-mail at "resume" for 10.0.It is all one line
in my Menu.1st. I also attached a text file.

Thanks for your patience

Bob S
# Modified by YaST2. Last modification on Tue Feb 6 22:12:27 EST 2007
default 4
timeout 15
gfxmenu (hd2,0)/boot/message

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.2
root (hd2,0)
kernel /boot/vmlinuz-2.6.18.2-34-default root=/dev/sda1 vga=0x31a resume=/dev/sda2 splash=silent showopts
initrd /boot/initrd-2.6.18.2-34-default

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
rootnoverify (hd0,0)
chainloader (hd0,0)+1

###Don't change this comment - YaST2 identifier: Original name: floppy###
title Floppy
rootnoverify (hd0,0)
chainloader (fd0)+1

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 10.2
root (hd2,0)
kernel /boot/vmlinuz-2.6.18.2-34-default root=/dev/sda1 vga=normal showopts ide=nodma apm=off acpi=off noresume edd=off 3
initrd /boot/initrd-2.6.18.2-34-default

### Added 10.0 Boot ###
title openSUSE 10.0
root (hd1,0)
kernel /boot/vmlinuz-2.6-15.13-default root=/dev/hdb1 vga=0x31a resume=/dev/hdb2 splash=silent showopts
initrd /boot/initrd-2.6-15.13-default
< Previous Next >