Mailinglist Archive: opensuse (2224 mails)

< Previous Next >
[opensuse] how to update alsa to 1.0.14rc2 on Suse 10.1 with checkinstall?
  • From: "Gustav Degreef" <gustav97@xxxxxxxxx>
  • Date: Sat, 3 Feb 2007 12:38:10 -0500
  • Message-id: <f29c8dd30702030938t692f3bd3rf80379cdf73ddfc@xxxxxxxxxxxxxx>
I hope someone can shed some light on this problem. I've been working
on this for months and have tried the alsa users list.

I would like to update alsa to try to get a micorophone to work with
my laptop. I am using Suse 10 .1 with kernel 2.6.16.27-0.6-smp. The
sound card on my laptop (a HP DV2035us) works but not the microphone.

some specs on my soundcard:
#lspci
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High
Definition Audio Controller (rev 02)
#cat /proc/asound/dev0/codec#0
Codec: Generic 14f1 ID 5047

I have

alsa-firmware-1.0.13-0.pm.0
alsa-devel-1.0.13-0.pm.0
alsa-docs-1.0.13-0.pm.0
alsa-plugins-1.0.10-15
alsa-tools-gui-1.0.11-16
alsa-tools-1.0.13-0.pm.1
alsa-1.0.13-0.pm.0
alsamixergui-0.9.0rc1-558

The following tar.bz2 packages are availbble from

ftp://ftp.alsa-project.org/pub/driver

* Driver 1.0.14rc2
* Library 1.0.14rc2
* Lib-plugins 1.0.14rc2
* Utilities 1.0.14rc2
* Tools 1.0.14rc1
* Firmware 1.0.14rc2
* OSS Compat. Library 1.0.12

But I want to maintain the integrity of the rpm database by creating
rpms of those packages using checkinstall.

I did the following:

$> bunzip2 alsa-driver-1.0.14rc1.tar.bz2
$> tar -xvf alsa-driver-1.0.14rc2.tar
$> ./configure --with-debug=full --with-cards=hda-intel
$> make
$> su -, then root passwd :
$#>checkinstall

I built rpm's of all the new (1.0.14rc2) packages I listed in the same
way. Then installed the seven new rpm's

rpm -Uvh alsa*.rpm

found all the audio modules
$#> lsmod |grep -i snd

Removed all modules
$#>rmmod snd_hda_intel
$#>rmmod snd_hda_codec
$#>rmmod snd_pcm
$#>rmmod snd_timer
$#>rmmod snd
$#>rmmod soundcore
$#>rmmod snd_page_alloc

$#>modprobe snd-hda-intel

$#>alsamixer

The new driver worked better and with alsamixer I got many more
channels than with the original 1.0.13-0. The problem came when I
rebooted - the card failed to work. I ran alsaconf and that seemed
to work, but the Yast sound configuration tool fails to configure the
card properly.

Should I keep both the alsa-1.0.13-0.pm.0 rpm when installing the
alsa-driver-1.0.14rc2.rpm that I created? I tried removing the
alsa-1.0.13-0.pm.0 rpm, but then alsamixer does not exist. Which - if
any - of the old (1.0.13-0) packages should I keep and which of the
new tar.bz2 (1.0.14rc2) should I install?
Any help would be appreciated. Thanks in advance, Gus Degreef.
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups