Mailinglist Archive: opensuse (4656 mails)

< Previous Next >
[opensuse] Firmware upgrade of Prism2 wireless adapter
  • From: "Gabriel - EA6VQ" <ea6vq.1@xxxxxxxxx>
  • Date: Sun, 28 Jan 2007 16:01:02 -0000
  • Message-id: <BJEMLCOEMMNJBMNCBEPEGEADIFAA.ea6vq.1@xxxxxxxxx>
I'm using SuSE 10.2 and I want to update the firmware of a wireless card
with the Prism2 (2.5) chipset. I have tested many things but I still can't
understand why it's not working, so I would appreciate very much any help
from the experts.

To update de firmware I use the command "prism2_srec -v -f wlan2
pk010101.hex sf010704.hex" but it returns an error saying that I have to
define PRISM2_DOWNLOAD_SUPPORT in driver/module/hostap_config.h

I understand that the hostap drivers are part of the 2.6.18 kernel, so I
have installed the kernel sources and I have verified that the DEFINE of
both PRISM2_DOWNLOAD_SUPPORT and PRISM2_NON_VOLATILE_DOWNLOAD are not
commented, in the hostap_config.h that is located in
/usr/src/linux/drivers/net/wireless/hostap.

Even so, I have compiled the kernel and restarted with the new kernel, but
the prism2_srec is still returning the same error. What am I doing wrong?

Thanks for any possible suggestion.

Gabriel

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages