Mailinglist Archive: opensuse (4626 mails)

< Previous Next >
RE: [opensuse] fsck running amok
On Wednesday, January 17, 2007 @ 8:26 PM, Sunny wrote:

>On 1/17/07, Greg Wallace <gregwallace@xxxxxxxxxxx> wrote:

>>
>> Sounds like a good idea. It's been a long time since I've worked in
other
>> than graphical mode. I tried CTRL-ALT-PF2 and then tried to unmount the
>> partition but it says it's busy. I've rarely worked in non-graphical
mode.
>> Can you suspend the graphical mode via some set of keys, unmount the file
>> system and do an fsck, or do you have to boot up in non-graphical mode to
>> begin with. If the latter, how is that done. I seem to recall there
being
>> a way to hit some key and enter a number to tell the system what level to
>> boot to, but I can't remember the details.
>>

>CTRL-ALT-F2
># su
># init 3

>This will switch to runlevel 3 w/o need to reboot.

>But, if the partition in case is the one, which is used for / , then
>this will not help.

>Boot with the install cd/dvd, and select maintenace mode or whatever
>it is called.

>This will boot from the install media, and will not mount the root
>filesystem. You will be able to fsck from there.

>--
>Svetoslav Milenov (Sunny)

Well, I booted into Rescue mode from the installation media and ran e2fsck.
When I did, I got the following message --

Superblock last write time is in the future Fix(y)?

I said fix and it came back saying the volume was clean. I then rebooted
normally and it still ran an fsck. So, I went back and booted from the
rescue disk again, ran another e2fsck, and got that same message about the
superblock last write time being in the future. I again fixed it, rebooted,
and it still runs an fsck. Really strange.

Greg Wallace


--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
This Thread
Follow Ups