Mailinglist Archive: opensuse (4626 mails)

< Previous Next >
[opensuse] Re: Timesync problem
  • From: Joachim Schrod <jschrod@xxxxxxx>
  • Date: Tue, 16 Jan 2007 02:16:18 +0100
  • Message-id: <eoh912$4vr$1@xxxxxxxxxxxxx>
Verner Kjærsgaard wrote:
Hi list,

- I've read and searched and read and searched all vmware docs and more...and still, I take the liberty to ask this list. Its got a little to do with SuSE10.2, so please forgive me...

- I'm running SLES10 as a host OS onto which I'm running a number of SuSE10.2s using vmware server. My time in the quests is way off. I set it using ntpdate -s on the clients. Then I initiate ntpd on the client. Or not, no difference. The time in my clients lacks behing by several hours/day.
- I'm currently trying a real dirty hack...on the client I'm running a cronjob every 10 minutes, doing a ntpdate -s -b IP-OF-TIMESERVER. I tried that hack by running the cronjob every 30 minutes, - but that didn't work...

- any hints?

AFAIK, this happens if your host system is an SMP system (i.e., with multiple CPUs) and your guest system is configured as a single-processor CPU. The VMware instance seems to see only half of the jiffies on a 2-CPU system, or something like that.

I don't know a way to resolve it short of configuring the VMware instance to use several CPUs as well.

On the other hand, it's not only a matter of SMP kernels on the host system. On my personal workstation, I have hyperthreading enabled and use therefore an SMP kernel as well. But my VMware-Server-Windows instance that I run here is always perfectly synchronized. I have seen the problem only with true SMP systems.

Maybe this observation helps,

Joachim

--
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Joachim Schrod Email: jschrod@xxxxxxx
Roedermark, Germany

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups
References