Mailinglist Archive: opensuse (3831 mails)

< Previous Next >
[opensuse] Re: recommend me a password manager?
  • From: email.listen@xxxxxxxxxxxxxx
  • Date: Mon, 8 Jan 2007 08:44:22 +0100
  • Message-id: <200701080844.28585.email.listen@xxxxxxxxxxxxxx>
Am Mon, 8. January 2007 07:10 schrieb Zhang Weiwu:
> 在 2007-01-07日的 23:09 +0100,email.listen@xxxxxxxxxxxxxx写道:
>
> > Am Sun, 7. January 2007 15:44 schrieb Zhang Weiwu:
> > > Dear All
> > >
> > > I have been comparing all different password managers for some time,
> > > and run pwman on FreeBSD and Figaro's Password Manager on SuSE 10.1 for
> > > some months (not satisfied by FPM). Now I have a fresh 10.2
> > > installation and I am looking for suggestions on the list.
> > >
> > > It seems there are too few avaiable password managers on the SuSE
> > > sources. What I need is pretty simple: I need a password manager that
> > > either work as X application or as console application. As X
> > > application it should use gtk2 (not gtk1) and better be dockable to the
> > > notification area or run as gnome panel applet. That's all ^_^
> >
> > May be revelation will [1] fullfill your needs.
> > It's a gtk2 application and has a gnome-panel applet.
> > But afaik it is not for console use / don't accept console commands for
> > opening it's stored data.
> >
> > > pwman is not found on SuSE as wellas on packman/Guru package
> > > collection.
> >
> > You may compile it from the source tarball?
> > Such small applications will compile quite easy and flawless, mostly.
>
> Thank you for your nice recommendation. I truly wish to try it a bit
> because from the screenshot looks very nice to me and has ALL features I
> need (and I won't need to manually transfer my FPM password set to it).
Did you have a look at:
http://en.opensuse.org/Additional_YaST_Package_Repositories

May be there is a site which has a revelation rpm.

>
> I cannot succesfully compile it yet, because it complain for a package
> 'gnome-python-2.0' not found. This package do not exist on SuSE 10.2 but
> a similiar package called 'gnome-python-desktop' is already installed.

I was thinking of compiling pwman (which is a console application and don't
need gui development libs as kde and gnome apps do) not of revelation. Pardon
me for not making this clear enough.

>
> I am a C language newbie plus compiler / Makefile stuff newbie, I am
> afraid tweak Makefile this is not what I can handle. Would be very glad
> if someone make an rpm package out of this package.
I haven't compiled revelation so far.
It seems that you need to install at least one of the following development
rpm's:

python-gnome2-dev - Python bindings for the GNOME desktop environment
python-gnome2-desktop-dev - Python bindings for the GNOME desktop environment
python-gnome2-extras-dev - Python bindings for the GNOME desktop environment


But I would suggest to have a closer look at the 'additional repositories'
first.

regards,
thomas
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >