Mailinglist Archive: opensuse (4634 mails)

< Previous Next >
Re: [opensuse] Problems to reinitialise proper hardware detection and configuration storage with SaX2
  • From: Matthias Hopf <mhopf@xxxxxxx>
  • Date: Mon, 18 Dec 2006 16:07:13 +0100
  • Message-id: <20061218150713.GD28447@xxxxxxx>
On Dec 18, 06 14:42:29 +0100, Markus Elfring wrote:
> I have noticed a few quirks while viewing a video in the Firefox browser. I shutdown the corresponding Gnome session. When I tried to login again a bit later, I have noticed that the mouse pointer did not move. My mouse MX&#8482; 600 previously worked also with the setting "MX310". (If I remember it correctly, it was autodetected as unknown device type 127 before my manual adjustment for the hardware "Cordless Desktop".)
> http://www.logitech.com/index.cfm/products/details/DE/EN,CRID=2162,CONTENTID=10709
>
> I was stuck with navigation by keys. So I switched to the command line to reset the expected values.
> (It was an unpleasant experience to move through the input fields with the tab key. Some accelerators/access keys seemed to get ignored.)
> http://en.opensuse.org/SDB:X_Server_Configuration_with_SaX2_%288.1_or_Higher%29
> /root> init 3
> [...]
> /root> sax2 -r
>
> I have noticed a few moments later that the entry "<none>" was shown for the mouse and a Microsoft model was displayed for the keyboard. I set the appropriate values.

Hm. For me this rather sounds like hardware failure than anything else.
Can you check the output of

hwinfo --mouse

? You might want to try a hard reset (including switching off power) as
well, before trying to reconfigure the mouse with 'sax2 -r'.

If you cannot get any mouse events printed by

evtest /dev/input/event* (you have to select the right one by trying)

then either your hardware is broken, or the kernel isn't detecting your
mouse any longer. If a different version of SuSE still works, create a
bug report.

Matthias

--
Matthias Hopf <mhopf@xxxxxxx> __ __ __
Maxfeldstr. 5 / 90409 Nuernberg (_ | | (_ |__ mat@xxxxxxxxx
Phone +49-911-74053-715 __) |_| __) |__ labs www.mshopf.de
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
References