Mailinglist Archive: opensuse (4634 mails)

< Previous Next >
Re: Fwd: Re: [opensuse] Using aria2
  • From: Susemail <susemail@xxxxxxxxxxxxx>
  • Date: Thu, 14 Dec 2006 23:22:42 -1000
  • Message-id: <200612142322.42937.susemail@xxxxxxxxxxxxx>
On Thursday 14 December 2006 12:08, Patrick Shanahan wrote:
> * Susemail <susemail@xxxxxxxxxxxxx> [12-14-06 15:20]:
> > # aria2c -help | grep log
> > -l, --log=LOG The file path to store log. If '-' is
Does LOG refer to the log file? If I use '-l' then aria2c -l logfile is the
correct syntax? But if I use '-log' then it's aria2c --log=logfile?
> > specified, log is written to stdout.

What is the command to get aria2c to print to stdout?
> >
> > # aria2c -l -
> > specify at least one URL
> > Usage: aria2c [options] URL ...
> > aria2c [options] -T TORRENT_FILE FILE ...
> >
> > Options:
> > -d, --dir=DIR The directory to store downloaded file.
> > -o, --out=FILE
> > ...................snip
> > #
> >
> >
> > # aria2c -l /home/myhome/aria2c.log
> >
> > This will not execute. No errors reported, the command is simply erased.
> It's a _reading_ problem...
> aria2c -l ~/aria2c.log -T <torrent_file>
' Usage: aria2c [options] URL ...
aria2c [options] -T TORRENT_FILE FILE ...'
I see you left out 'URL' in your example. Because it is optional?
This is confusing. What is a Torrent file? Is *.metalink a torrent file?
Which torrent file is expected here. I need to set up a log file in order
to find out why there is an error (where there should be no error-this should
just work imho). Can you tell me the command using this program that will
create the log file so I can move on. The best I can come up with based on
the man pages and emails is:

aria2c -l ~/aria2c.log -T openSUSE-10_2-GM-DVD-i386_iso.metalink
which doesn't work: malformed meta data. Which raises another question.
Which part of this statement is meta data? All I see is a
command:'aria2c';an option '-l';a file: ' ~/aria2c.log'; another option:'T';
and another file:'openSUSE-10_2-GM-DVD-i386_iso.metalink'

> The error response from the program told you that a torrent parameter
> was necessary
> > # man aria2c
> > No manual entry for aria2c
> 17:01 wahoo:~ > rpm -ql aria2|grep gz
> /usr/share/man/man1/aria2c.1.gz
> > So 'aria2c -l -' gives me the help menu, I thought it would print the log
> > to stdout. 'aria2c -l '-' ' just
> > disappears. 'aria2c -l /home/myhome/aria2c.log' doesn't execute or
> > return it just disappears. I thought it would use aria2c.log to store
> > the log.
> same as my first comment
> aria2c -l ~/aria2c.log -T <torrent_file>
> > There are no man pages on my system. They should be in /usr/local/man.
> > I started with aria2-0.9.0.tar.bz2
> why are you installing tar-balls on an rpm based system when there are
> rpms build for your system available? no, no, no
I went to the sourceforge page for aria2 and there were no suse rpms. I
didn't think to check anywhere else. I have now installed the rpm on top of
the install. Now I have the man pages but I didn't need them since
you had copied the log data in your response. I still get the same error

> >
> > How do I make this work?
> use the rpm files and read the error/help comments provided by the
> program.
So far the program isn't providing any error/help messages except look in
places that don't exist for the error message.
> --
This is a lot of effort for something that should be easy to do.

Thanks for your help,
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups