Mailinglist Archive: opensuse (4446 mails)

< Previous Next >
[opensuse] OpenOffice.org only 32bit?
  • From: Thibaut Cousin <linux@xxxxxxxxxxxxxxxxxx>
  • Date: Sun, 10 Dec 2006 11:27:26 +0100
  • Message-id: <200612101127.31140.linux@xxxxxxxxxxxxxxxxxx>
Hello,

I installed the x86_64 version of 10.2, everything works fine. :-)
I was only surprised to see that OpenOffice.org is only available as 32bit.
A quick look in the source RPM shows the reason: it doesn't work with Sun
Java in 64bit. I don't understand: in 10.1, I had both in 64bit and it worked
well.
Anyway, could it work with GCC-Java 64bit? I've tried recompiling it, but it
failed (I forgot the error message, so I'm trying again now to get it).
The result, through RPM dependency, is a mess of 32bit packages that waste
space in my system. In 10.1 I was able to remove almost all of them by
installed 64bit versions of everything.

Would it be possible to provide 64bit packages of OpenOffice.org relying on
another Java like GCC-Java? Does it alreadly exist in a RPM-MD repository?
Thanks in advance,

--
Thibaut Cousin
http://www.thibaut-cousin.net
< Previous Next >
Follow Ups