Mailinglist Archive: opensuse (4446 mails)

< Previous Next >
[opensuse] Compiling a metalink client - aria2 - impossible
  • From: "Carlos E. R." <robin.listas@xxxxxxxxxxxxxx>
  • Date: Wed, 6 Dec 2006 17:09:41 +0100 (CET)
  • Message-id: <Pine.LNX.4.64.0612061702550.20164@xxxxxxxxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


Hi,

I'm trying to get ready the aria2 metalink client (aria2-0.9.0.tar.bz2) in
time for the suse 10.2 release. I get this error in the configure run:

checking for xml2-config... /usr/bin/xml2-config
checking for libxml - version >= 2.6.24...
*** An old version of libxml (2.6.23) was found.
*** You need a version of libxml newer than 2.6.24. The latest version of
*** libxml is always available from ftp://ftp.xmlsoft.org.



It wants xml2 version 2.6.24, and SuSE 10.1 has 2.6.23: thus xml support
will not be compiled. This is necesary for metalink support:

|Dependency
|
| For HTTPS support, you need GNU TLS or OpenSSL.
| For BitTorrent support, you need GNU TLS+libgcrypt or OpenSSL.
| In order to enable Metalink support, you need libxml2. Optionally GNU
| TLS+libgcrypt or OpenSSL are required for checksum checking support(MD5, SHA1).
| For asynchronous DNS support, you need c-ares or ares.


So... where do we get a metalink program for 10.1, preferably as a ready
made rpm?


- --
Cheers,
Carlos Robinson

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Made with pgp4pine 1.76

iD8DBQFFdutHtTMYHG2NR9URAsaOAJ9XF4F8mE6iLrdox+lcOpbFjI1b4QCeORhk
eCRMLuUnNl1VlVeYwmJ+Xb8=
=clay
-----END PGP SIGNATURE-----

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups