Mailinglist Archive: opensuse (4219 mails)

< Previous Next >
Re: [opensuse] xmms and mp3 - RC1
  • From: John Andersen <jsa@xxxxxxxxxxxxxx>
  • Date: Tue, 5 Dec 2006 09:59:34 -0900
  • Message-id: <200612050959.35584.jsa@xxxxxxxxxxxxxx>
On Tuesday 05 December 2006 09:51, Jan Engelhardt wrote:
> >> >Just add this packman mirror to your installation sources :
> >>
> >> No, that would pull in a bunch of unnecessary packages. Until smart
> >> supports the "experimental" channel, it's deactivated.
> >
> >No it does not "pull in a bunch of unnecessary packages".
> >
> >Where did you get the impression that everything in a repository
> >is "pulled in"?
>
> 19:49 ah:~ # smart channel --enable packman
>
> 19:49 ah:~ # smart upgrade
> Loading cache...
> Updating cache... ########################################
> [100%]
>
> Computing transaction...
>
> Upgrading packages (16):
> alsa-1.0.13-0.pm.0@i586 libtheora-1.0alpha7-0.pm.0@i686
> alsa-devel-1.0.13-0.pm.0@i586
> libtheora-devel-1.0alpha7-0.pm.0@i686 alsa-firmware-1.0.13-0.pm.0@noarch
> libxml2-2.6.26-0.pm.1@i586 alsa-tools-1.0.13-0.pm.1@i586
> libxml2-devel-2.6.26-0.pm.1@i586 boost-1.33.1-17.pm.2@i586
> libxml2-python-2.6.26-0.pm.1@i586 hplip-hpijs-1.6.9-5.pm.1@i586
> mpg321-0.2.10-530@i586
> jack-0.102.20-0.pm.1@i586 speex-1.1.99_1.2beta1-0.pm.0@i686
> libsndfile-1.0.17-0.pm.3@i586 xvid-1.1.2-0.pm.0@i686
>
> Installing packages (5):
> libid3tag-0.15.1b-32@i586 portaudio18-devel-18.1-0.pm.2@i586
> mad-0.15.1b-1.pm.3@i586 sqlite-3.2.8-14@i586
> portaudio18-18.1-0.pm.2@i586
>
> 21.0MB of package files are needed. 36.8MB will be used.

So what's you point?

Packman has newer packages and it upgrades those.
You don't have to accept any given upgrade if you don't want.

These have dependencies, which are also satisfied.

That list is FAR from the total packages on packman.

--
_____________________________________
John Andersen
< Previous Next >
Follow Ups