Mailinglist Archive: opensuse (2835 mails)

< Previous Next >
Re: [opensuse] OOo Java Issue
  • From: Dave Barton <db@xxxxxxxxx>
  • Date: Tue, 05 Dec 2006 16:46:38 +1100
  • Message-id: <1165297598.3914.79.camel@xxxxxxxxxxxxx>
On Mon, 2006-12-04 at 10:35 -0500, BandiPat wrote:
> On Monday 04 December 2006 06:37, Dave Barton wrote:
> > I am running the Novell 64 bit edition of OOo 2.0.4 on SuSE 10.1
> > x86_64 and I have Sun's 64 bit JRE 1.5 update 7 installed. OOo's Java
> > options finds the installed JRE , but any attempt to use any of OOo's
> > Java based functions returns an error. For example, try to create a
> > simple address database table results in the following error:
> >
> > SQL Status: S1000
> > Error code: 1000
> > No Java installation could be found. Please check your
> > installation!
> >
> > Has anyone here experienced a similar problem, or am I trying to
> > achieve the impossible.
> >
> > TIA
> >
> > Dave
> ========
>
> I think all you may need to do here is run the OOo admin or setup
> program again and point it to the correct Java. I know mine was
> confused also and it may have been because I had 1.4.2 & 1.5 installed
> or something about the SUSE build, not sure. Running the setup again
> though proved to be the thing that fixed it. Now I don't get anymore
> complaints from OOo.

Thanks for taking the time to reply, but I am not clear about what you
mean by "Running the admin/setup again". I installed the following:
OpenOffice_org-2.0.4-1.2.x86_64.rpm
OpenOffice_org-kde-2.0.4-1.2.x86_64.rpm
OpenOffice_org-mono-2.0.4-1.2.x86_64.rpm
OpenOffice_org-officebean-2.0.4-1.2.x86_64.rpm
and (with the exception of the Java dependent functions) everything,
including the VBA translations :-), just worked.

The OOo menu "Tools -> Options -> Java" shows me that OOo has found a
valid JRE in "usr/lib64/jvm/java-1.5.0-sun-1.5.0_07/jre"

I have tried renaming (hiding) my ~/.ooo-2.0 directory and starting OOo
again, but this makes no difference.
As a side note, the Novell edition does not offer the "first time use
dialog" that the "official" edition does.

Am I missing something obvious in this configuration?

Dave

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
References