Mailinglist Archive: opensuse (2835 mails)

< Previous Next >
[opensuse] Can anyone run GTK Emacs with wxGTK installed?
  • From: Stephen Berman <Stephen.Berman@xxxxxxx>
  • Date: Mon, 04 Dec 2006 11:42:58 +0100
  • Message-id: <87hcwc9c25.fsf@xxxxxxxxxxxxxxxxx>
I posted here on Friday about Emacs 22 built with GTK support
segfaulting after I installed wxGTK on SUSE 10.1 (MID
<87hcwf8j70.fsf@xxxxxxxxxxxxxxxxx>) and haven't gotten any reply yet.
I would be grateful if anyone who uses the GTK build of Emacs 22 could
test this on their system (preferably 10.1 or 10.0), so I can know
whether this is a SUSE problem or a local issue. All you have to do
is install the wxGTK rpm and the see if you can start GTK Emacs
(builds with other X11 toolkits are not affected). If Emacs
segfaults, you just have to uninstall the wxGTK rpm, and Emacs should
start again as usual. (However, don't build and install wxGTK from
source: I did that in the hope of solving this problem, but the
Makefile has an empty uninstall target and even after deleting all wx*
files by hand, I still cannot start GTK Emacs, and haven't gotten
anywhere yet trying to find out why.) I would appreciate any and all
feedback.

Steve Berman

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx

< Previous Next >
Follow Ups