Mailinglist Archive: opensuse (2831 mails)

< Previous Next >
Re: [SLE] Re: RealPlayer10 +Suse 10.1, no video
  • From: Art Fore <art.fore@xxxxxxxxxxx>
  • Date: Sat, 08 Jul 2006 09:31:47 -0700
  • Message-id: <1152376307.4535.21.camel@xxxxxxxxxxxxxxxxxx>
On Sat, 2006-07-08 at 23:52 +0900, Masaru Nomiya wrote:
> Hello,
>
> >>>>> In the Message: [suse-linux-e ML: No.276341]
> >>>>> with the date of Fri, 07 Jul 2006 21:29:22 -0700
> >>>>> [Art] == Art Fore <art.fore@xxxxxxxxxxx> has written:
>
> Art> The plugin is in /usr/lib/browser-plugins. If I try to play a downloaded
> Art> file, all I get is the audio, no video. This is the same when I try a
> Art> streaming video from cbsnews.com.
>
> First of all, which SuSE are you using?
> Two. Which browser are you using?
> Isn't it the x86_64 version?
>
> On the terminal. enter your browser, then you will get the messeges
> concerning the plugin files.
>
> Regards,
>
> ---
> Masaru Nomiya mail-to: nomiyac360 @ mg.point.ne.jp
>
> "Bill! You married with Computers.
> Not with Me!"
> "No..., with money."
>
It is Suse 10.1 32-bit on Inspiron 8500 w/P4m, nvidia GeGorce4 Go, 1 gig
ram. It now works in Firefox, but not in opera.

When I open Opera, I get 3 instances of realplay.bin, one of which is
running, 1 instance of realplay, which is sleeping, and two instances of
operapluginwrapper, one sleeping, and 1 running. Her is console output
when I open opera from the console

Calling realplay
playeripc: Got command Version 1
playeripc: Got command Embed name='vplayer1028'
TYPE='audio/x-pn-realaudio-plugin' controls='ImageWindow' autostart='1'
nojava='1'
scriptcallbacks='OnPresentationClosed,OnPresentationOpened,OnPlayStateChange,OnPosLength,OnBuffering' width='320' height='240' hspace='0' vspace='0'
playeripc: Got command Browser 0 'Mozilla/5.0 (X11; Linux i686; U; en)
Opera 9.00' 0 0
playeripc: Got command SetXID 0 88080387 0 0 1 1 0 0 0 0 1
playeripc: Got command SetXID 0 88080387 0 0 480 360 0 0 0 0 1
playeripc: Got command UnsetWindow 0
All consoles have been closed
playeripc: Got command Embed name='vplayer1480'
TYPE='audio/x-pn-realaudio-plugin' controls='ImageWindow' autostart='1'
nojava='1'
scriptcallbacks='OnPresentationClosed,OnPresentationOpened,OnPlayStateChange,OnPosLength,OnBuffering' width='320' height='240' hspace='0' vspace='0'
playeripc: Got command Browser 1 'Mozilla/5.0 (X11; Linux i686; U; en)
Opera 9.00' 0 0
playeripc: Got command SetXID 1 88080389 0 0 1 1 0 0 0 0 1
playeripc: Got command SetXID 1 88080389 0 0 480 360 0 0 0 0 1
playeripc: Got command UnsetWindow 1
All consoles have been closed
playeripc: Got command Embed name='vplayer1889'
TYPE='audio/x-pn-realaudio-plugin' controls='ImageWindow' autostart='1'
nojava='1'
scriptcallbacks='OnPresentationClosed,OnPresentationOpened,OnPlayStateChange,OnPosLength,OnBuffering' width='320' height='240' hspace='0' vspace='0'
playeripc: Got command Browser 2 'Mozilla/5.0 (X11; Linux i686; U; en)
Opera 9.00' 0 0
playeripc: Got command SetXID 2 88080391 0 0 1 1 0 0 0 0 1
playeripc: Got command SetXID 2 88080391 0 0 480 360 0 0 0 0 1

If I click on one of the cbsnews videos I get the follow

playeripc: Got command UnsetWindow 2
All consoles have been closed
playeripc: Got command Embed name='vplayer1308'
TYPE='audio/x-pn-realaudio-plugin' controls='ImageWindow' autostart='1'
nojava='1'
scriptcallbacks='OnPresentationClosed,OnPresentationOpened,OnPlayStateChange,OnPosLength,OnBuffering' width='320' height='240' hspace='0' vspace='0'
playeripc: Got command Browser 3 'Mozilla/5.0 (X11; Linux i686; U; en)
Opera 9.00' 0 0
playeripc: Got command SetXID 3 88080393 0 0 1 1 0 0 0 0 1
playeripc: Got command SetXID 3 88080393 0 0 480 360 0 0 0 0 1
^[[B^[[B^[[Bplayeripc: Got command Embed name='vplayer1355'
TYPE='audio/x-pn-realaudio-plugin' controls='ImageWindow' autostart='1'
nojava='1'
scriptcallbacks='OnPresentationClosed,OnPresentationOpened,OnPlayStateChange,OnPosLength,OnBuffering' width='212' height='159' hspace='0' vspace='0'
playeripc: Got command Browser 4 'Mozilla/5.0 (X11; Linux i686; U; en)
Opera 9.00' 0 0
playeripc: Got command SetXID 4 88080395 0 0 1 1 0 0 0 0 1
playeripc: Got command SetXID 4 88080395 0 0 318 238 0 0 0 0 1
playeripc: Got command UnsetWindow 4
playeripc: Got command Embed name='vplayer1355'
TYPE='audio/x-pn-realaudio-plugin' controls='ImageWindow'
SRC='http://video.cgi.cbsnews.com/vplayer2/play2.pl?type=rm&prod=popup&arena=video&feat=vplayer&adtype=pre&id=1781981n&ord=6078.296643681824' autostart='true' nojava='true' scriptcallbacks='OnPresentationClosed,OnPresentationOpened,OnPlayStateChange,OnPosLength,OnBuffering' width='212' height='159' hspace='0' vspace='0'
playeripc: Got command Browser 5 'Mozilla/5.0 (X11; Linux i686; U; en)
Opera 9.00' 0 0
playeripc: Got command SetXID 5 88080397 0 0 318 238 0 0 0 0 1
playeripc: Got command SetXID 5 88080397 0 0 318 238 0 0 0 0 1
playeripc: Got command SetXID 5 88080397 0 0 318 238 0 0 0 0 1
playeripc: Got command NewStream 5 0
http://video.cgi.cbsnews.com/vplayer2/play2.pl?type=rm&prod=popup&arena=video&feat=vplayer&adtype=pre&id=1781981n&ord=6078.296643681824 application/smil 0

(realplay.bin:16904): GLib-CRITICAL **: g_io_channel_write_chars:
assertion `channel != NULL' failed
write: Broken pipe
Calling realplay
playeripc: Got command Version 1
playeripc: Got command Embed name='vplayer1014'
TYPE='audio/x-pn-realaudio-plugin' controls='ImageWindow' autostart='1'
nojava='1'
scriptcallbacks='OnPresentationClosed,OnPresentationOpened,OnPlayStateChange,OnPosLength,OnBuffering' width='320' height='240' hspace='0' vspace='0'
playeripc: Got command Browser 0 'Mozilla/5.0 (X11; Linux i686; U; en)
Opera 9.00' 0 0
playeripc: Got command SetXID 0 88080399 0 0 480 360 0 0 0 0 1
playeripc: Got command SetXID 0 88080399 0 0 480 360 0 0 0 0 1

realplay.bin, realplay, & operapluginwrapper all remain the ame.

If I do the same with firefox, I do not get the rea play instances until
I click on the cbsnews video, then I get 3 instances of realplay.bin,
all sleeping, and an instance of realplay with plugger-5.1.3 under it.
There is nothing on the console after involking firefox, Here is the
console output after I click oon the video

Warning: LD_PRELOAD="/usr/$LIB/libaoss.so"

There are then 4 instances of realplay.bin and one realplay. After the
video finishes, there are 3 reaplay.bin. I close realplayer window, all
of this goes away except the plugger-5.1.3

Art






--
Check the headers for your unsubscription address
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the archives at http://lists.suse.com
Please read the FAQs: suse-linux-e-faq@xxxxxxxx


< Previous Next >
Follow Ups