Mailinglist Archive: opensuse (2831 mails)

< Previous Next >
[SLE] yast: "Another process is accessing..."
  • From: stephan beal <stephan@xxxxxxxx>
  • Date: Thu, 13 Jul 2006 18:15:07 +0200
  • Message-id: <200607131815.11121.stephan@xxxxxxxx>
Hi, all!

i'm new to this list, and i apologize if this is not the place for this
type of question (if it is, please kindly ignore me or point me to the
proper place).

i'm using OpenSuse 10.1 and have the following problem:

Some days ago i tried to add an ftp site as an Installation Source using
yast. Each time i tried (3 or 4 times) yast hung (i waited for 5+
minutes each time) and i had to kill it. At some point it got in a bad
state, and now each time i try to use yast's Software Management or
Installation Source features i get the following error message:

"Another process is accessing the package database.
Package management will not work!"

There are no running yast processes except for the one i'm getting the
error in. i can find no stale lock files for older instances.

Other than the inability to add/remove software (or package
repositories) via yast my box is working just fine. i am able to
un/install RPMs directly from the command line.

Can someone please tell me what file(s) i need to nuke to get rid of
this error? i've tried re-installing the yast core RPMs, but that
hasn't helped. i don't mind hosing my current yast configuration in
order to get around this problem.

Note: i am an advanced user, so don't be afraid to suggest an ugly hack,
nor do you need to feel compelled to dumb down an answer for me. :)

Many thanks in advance for any tips...

--
----- stephan@xxxxxxxx http://s11n.net
"...pleasure is a grace and is not obedient to the commands
of the will." -- Alan W. Watts
< Previous Next >