Mailinglist Archive: opensuse (2831 mails)

< Previous Next >
[SLE] Create, mount, & share VFAT partition over home net using SuSE 10.0 box as server
  • From: kbboykin@xxxxxxxxxxx
  • Date: Sun, 16 Jul 2006 21:10:06 +0000
  • Message-id: <071620062110.14796.44BAAB2E00080F10000039CC220073436402070597010D0D05@xxxxxxxxxxx>
Hello List,

I have frustratingly tried to redo my SuSE server. SuSE 9.0 -> 10.0 (fresh install).

I had HD problems (lost grub and a repair keeps saying partition is corrupt even though I can mount it using CD1) and bought a new HD. The old HD had a partition called /public which I used to share data, programs, etc that are windows or non-secure linux with my closed home net (no ssh or internet access, strictly a home net). The partition on the old server was ext3 (maybe reisers, can't remember)

However, I want to partition this new HD, but now create this partition as a fat32 partition and automount it a boot for FULL access to all users to be shared across the home net. When I tried this root is the owner and no access is granted.

I have a smb.conf from the previous and brought that over to the new machine. i have put various and sundry mount(s) for this drive in fstab. Here is the most recent: /dev/hda1 /public vfat auto,noatime,rw,users 0 0
This does automount the partition, but WILL NOT allow me to create any directories. I can see the partition and all the files when I log in locally on the server, but that's it. It will not allow access over TCP/IP net.

Please, someone, give me a URL or a step x step as my brain ( I am a novice) is now mush for trying. I am about to give up and go back to making this an ext3 partition. I only want to make this a vfat so in the future if the server crashes, I can at least mount the fat32 partiton over the net using a net drive setup until I get the server back on line.

Many thanks in advance.
--Keith

--
Check the headers for your unsubscription address
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the archives at http://lists.suse.com
Please read the FAQs: suse-linux-e-faq@xxxxxxxx


< Previous Next >
This Thread
  • No further messages