Mailinglist Archive: opensuse (2831 mails)

< Previous Next >
Re: [SLE] module missing in the upgraded kernel
  • From: James Watkins <misterwatto@xxxxxxxxx>
  • Date: Mon, 17 Jul 2006 14:12:54 +0100
  • Message-id: <44BB8CD6.3000603@xxxxxxxxx>
Sunny wrote:
Hi,
10.0 x86_64 here.

I upgraded/updated the kernel to 2.6.13-15.10 (official).

It misses the dm-mod module compiled, so I'm really screwed. Non of my
LVM volumes can be mounted. And my /usr and /var are on logical
volumes :(

The previous kernel I used - 2.6.13-15.8 worked OK.

Can someone confirm that this is the case?

Where from I can get the previous version, so I can recover?


Hi Sunny, have you checked that you have the dm-mod.ko file, I think it
should be found under /lib/modules/2.6.13-15.10/kernel/drivers/md/ If
so, it may be that the installation procedure didn't create your initrd
with all the required drivers. If this is the case, you'll need to run
mkinitrd, I don't remember the proper syntax off the top of my head so
check out the man page. There is also a variable in
/etc/sysconfig/kernel called INITRD_MODULES which determines which
modules go into the initrd image, check this before using mkinitrd.

HTH,

James.


--
Check the headers for your unsubscription address
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the archives at http://lists.suse.com
Please read the FAQs: suse-linux-e-faq@xxxxxxxx


< Previous Next >
Follow Ups
References