Mailinglist Archive: opensuse (2831 mails)

< Previous Next >
[SLE] IMAP HowTo (was re: POP Mail HOWTO?)
Having read what both Anders and Joanne had to
say about setting up a simple mail server at
home, I... um... flipped a coin, and went with
Anders' version. So I followed the summary,
as ammended in the follow-up message.

He was specific about his procedure being
intended for a fresh system with no previous
mail-related config. So... yes... I reformatted
and re-installed SUSE 10.1. Blew away everything,
including /home - the only untouched partition
was /data. I restarted several times while the
installer/updater seemed to be working around the
Online Update problems that plagued the early
days of the release, and I appear to have gotten
all the necessary updates installed. Then I tackled
the mail setup following printouts of Anders'
e-mails with the instructions.

I did as much as I could as root, running SuSEconfig
every time I turned around. As part of that
effort, I created a link to my /data partition,
and (as emphasized by Anders) made very sure that
the target directory had the same ownership and
permissions as the original mail landing spot in /var.
Then I started everything and stood back and let
it rip. I had been piling up mail on my ISP for
some weeks (still am, since I used the 'keep' option
until this is working), so fetchmail went and got
thousands of messages.
I have no idea where they went, but it took more
than half an hour to get them all, via ADSL,
the first time. Thereafter, connections took
a few seconds, so I'm assuming it was getting
mail that hadn't already been retrieved in the
first lengthy batch.

I started Thunderbird to connect to Cyrus on
the same machine. I answered its initial questions
with responses that made sense to me at the time.
At first it wouldn't connect, so I tweaked saslauth
config and tried again. Thunderbird prompted for
my password and then made satisfied noises, but
no mail appeared in my INBOX (in Thunderbird).
I spent a few hours reading stuff in the Cyrus
docs and didn't really find anything that I was
sure I should be tweaking, so I tried something
else.

I figure that all the downloading activity meant
I must have thousands of messages SOMEwhere, and
I tried to find 'em. I know that Cyrus doesn't
use /Maildir, but I read that it _does_ store
messages as individual files, and uses databases
to handle all the meta info. I looked every place
I could imagine, on both /var and my /data partition,
as well as in /home (just in case), to no avail.
If I've got a load of downloaded mail somewhere,
it's well hidden.

Meanwhile, I came into my office this morning
and found dozens of bounce mails, from all the stuff
that I'd sent/forwarded from office to home over the
past several weeks. They looked like this:
****************************************************
Subject: Undelivered Mail Returned to Sender

This is the Postfix program at host junkbox.OURHOUSE.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to <postmaster>

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

The Postfix program

<elefino@xxxxxxxxxxxxxxxxxxxxxxxxxx> (expanded from <elefino@localhost>):
Host
or domain name not found. Name service error for
name=localhost.junkbox.OURHOUSE type=AAAA: Host not found
*************************************************************
Of course, I don't have a remote connection to fix anything
at home, so it's going to be doing this to all my mailing
lists and getting me disbarred, and possibly tarred and
feathered.

My real e-mail address is kevinmcl-รข-magma.ca, my ISP
being magma.ca.
"Junkbox" is the hostname of the machine on which
I've been trying to configure this domestic server,
and "OURHOUSE" is a made-up 'domain' that I inserted
when it appeared that I had to insert something.
I guess that would have been in postfix config (main.cf),
but I'm miles away from that box right now, so I
can't check.
Elefino is the username on that computer.
I'm guessing that something, somewhere inserted
"localhost" into the mix, because I never wrote
that explicitly. Maybe it was a default that I
didn't change in some config file, because it was
not mentioned in Anders' instructions. Dunno.
I thought I read (from Anders) that I should be
able to follow his instructions as written to get
a working IMAP server, and that if I foolishly
_wanted_ to do additional config-file tweaking,
that was 'beyond the scope' and asking for trouble.

So, does this mean that my mail never did come in?
That 30-to-40 minutes of modem activity and disk
churning was for naught?
Does it mean that the mail is all lying on my
hard disk somewhere but Cyrus-IMAP didn't accept
it?
Does it mean that Cyrus-IMAP is not working?
Or that Cyrus-IMAP has my mail, but isn't showing
it to me (via Thunderbird) and isn't acknowledging
to Postfix?

At least, when I left this morning, there was no
disk or modem activity, so I'll take comfort in
the possibility that maybe I didn't also configure
an open spam relay while goofing up everything else...

Kevin (unserved, still)

PS: Anders, hope your move to Germany went
smoothly.

PPS: Once all this was working, I was going to set up
another address to be <postmaster>.

The information contained in this electronic mail transmission may be privileged and confidential, and therefore, protected from disclosure. If you have received this communication in error, please notify us immediately by replying to this message and deleting it from your computer without copying or disclosing it.

--
Check the headers for your unsubscription address
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the archives at http://lists.suse.com
Please read the FAQs: suse-linux-e-faq@xxxxxxxx


< Previous Next >