Mailinglist Archive: opensuse (2831 mails)

< Previous Next >
Re: [SLE] Novell's official position on binary only kernel modules
  • From: BandiPat <penguin0601@xxxxxxxxxxxxx>
  • Date: Fri, 28 Jul 2006 10:47:24 -0400
  • Message-id: <200607281047.25014.penguin0601@xxxxxxxxxxxxx>
On Friday 28 July 2006 02:00, Marcus Meissner wrote:
[...]
> >
> > Ok, now I'm curious. Do you install both the rpm files for the ATI
> > cards or just one of them? Afterwards you need to run sax2 to set
> > for fglrx module rather than using the present radeon, right?
>
> Do not walk, but RUN! to this URL:
>
> http://www.suse.de/~sndirsch/ati-installer-HOWTO.html
>
> It explains all in detail.
>
> Ciao, Marcus
==========
Thanks Marcus,
That helps and I did play a bit last evening with this thing. I'm not
sure the present drivers are setup for the 2.6..16.21-0.13 kernel
though as the install added a directory for 2.6.16.21-0.8 kernel and
dropped the fglrx.ko module into an updates directory there.

I was still able to get sax2 to run with:
sax2 -r -m 0=fglrx

All seemed to work well, everything setup just as before, a new
xorg.conf file was created with all the ATI stuff there. But when I
restarted X, I didn't have any direct rendering, thus no 3d running.

I tried a few things, like adding the fglrx.ko module to the newer
kernel "updates" folder, but nothing helped. I ran aticonfig also
without success. The only thing I didn't do was drop the module into
the drm folder of the new kernel, so don't know if that would be the
answer or not.

Anyone here have thoughts or solutions for the problem?

thanks,
Lee

--
Check the headers for your unsubscription address
For additional commands send e-mail to suse-linux-e-help@xxxxxxxx
Also check the archives at http://lists.suse.com
Please read the FAQs: suse-linux-e-faq@xxxxxxxx


< Previous Next >