Mailinglist Archive: opensuse (2831 mails)

< Previous Next >
Re: [SLE] Yast2 online update Problem
  • From: Andreas Jaeger <aj@xxxxxxx>
  • Date: Fri, 28 Jul 2006 17:32:21 +0200
  • Message-id: <m33bcl924a.fsf@xxxxxxxxxxx>
Mike Coan <mikecoan@xxxxxxxxxxxxxxxxxxxxxx> writes:

>> [stuff deleted]
>>
>> Can you try updating _all_ packages found there?
>>
>> Above problem is a mismatch between the packages "libzypp" and
>> "yast2-packagemanager", both need to be at the same level.
>>
>> Ciao, Marcus
>
> Thank you for the quick response. I am using the following site for updates
>
> mirrors.kernel.org/suse/x86_64/update/10.1/rpm
>
> There are the following directories
>
> i586
> i686
> noarch
> ppc
> ppc64
> src
> x86_64
>
> Previously all updates had been done through YAST. I do have all the latest
> version of libzypp and yast2-packager as listed in the x86_64 directory.

What about the noarch directory? You need those as well.

> I notice that there are some rpm packages in the noarch directory related to
> yast that are later than what I have. Should I make sure that all the noarch
> packages are also the latest?

Yes, exactly.

> Also would it pay to "force" the installation of libzypp and yast2-packager?
> Both rpm -Uvh and rpm -ivh give the indication that the packages are already
> installed. I could do an rpm -e and remove them and reinstall.

Or use:
rpm -Uhv --force

Give it a try.

> In any event the libzypp and yast2-packager rpms are the latest.


Andreas
--
Andreas Jaeger, aj@xxxxxxx, http://www.suse.de/~aj/
SUSE Linux Products GmbH, Maxfeldstr. 5, 90409 N├╝rnberg, Germany
GPG fingerprint = 93A3 365E CE47 B889 DF7F FED1 389A 563C C272 A126
< Previous Next >
Follow Ups