Mailinglist Archive: opensuse (5130 mails)

< Previous Next >
Re: [SLE] Changing hardware IRQ's
  • From: Carl Hartung <suselinux@xxxxxxxxxxxxx>
  • Date: Tue, 2 May 2006 08:25:28 -0400
  • Message-id: <200605020825.29235.suselinux@xxxxxxxxxxxxx>
On Monday 01 May 2006 10:08, Sunny wrote:
> ASUS A8AE-LE. Here is a link to mobo specs on hp site:
<snip>

Hi Sunny,

From the specs:
BIOS:
4Mb LPC EEPROM
HP BIOS with enhanced ACPI, DMI, Green, and PnP Features Plus

Theoretically, the HP BIOS could be 'optimized' to support some factory
installed (M$?) software. You could test this by flashing the BIOS with an
'off-the-shelf' image from ASUS. I'm not convinced this is your problem,
however.

> ... I can not use the mike - it breaks after 2-3 sec of working, I
> tried skype, and other recording programs. I tried both 64 and 32 bit
> SuSE 10, Knoppix 32 bit. It is always the same.

First, I wouldn't expect an IRQ problem to exhibit a symptom like this. The
device should either be recognized, initialized and work... or not, if the
problem is really IRQ. If you drop to 8KHz sampling rate x 8 bit samples,
does the recording time increase before the microphone "breaks?" This could
be a broken buffering scheme, i.e. software bug (broken module?)

What happens if you do a 'line' recording?... if you record from streaming
radio, does it also go silent after a second or two?

> I know from the kernel lists that there is a problem with the APIC
> support for some SiS mobo's, so I hope that if I can set the IRQ for
> the sound to something else, it may work.

Have you tried all of the relevant boot kernel parameters?
/usr/src/linux-{version}/Documentation/kernel-parameters.txt

regards,

Carl


< Previous Next >
References