Mailinglist Archive: opensuse (5130 mails)

< Previous Next >
Re: [SLE] Software updater
  • From: Carl Hartung <suselinux@xxxxxxxxxxxxx>
  • Date: Wed, 17 May 2006 17:13:35 -0400
  • Message-id: <200605171713.36074.suselinux@xxxxxxxxxxxxx>
On Tuesday 16 May 2006 23:14, Erik Jakobsen wrote:
> How do I get it updated ?.

Erik,

I just posted this on suse-kde. I don't know if you subscribe to that list and
thought this might be helpful.

hth & regards,

Carl

When I first installed SUSE 10.1, I had problems with the new 'online update'
system loading down my system and being very uninformative (i.e. cryptic.)
After reading a couple of posts on SLE, I uninstalled the following packages:

suseRegister
rug
zen-updater
zmd
libzypp-zmd-backend (maybe I kept this one due to dependencies?)

Then I added the following installation sources in YaST:

Base system:
http://{mirror}/distribution/SL-10.1/inst-source
http://{mirror}/distribution/SL-10.1/non-oss-inst-source

The "unofficial" supplementary KDE 3.5.2 'level a' upgrade:
ftp://ftp.suse.com/pub/suse/i386/supplementary/KDE/update_for_10.1/yast-source

Bug fixes and security patches:
ftp://{mirror}/pub/suse/i386/update/10.1

Packman packages repository:
http://packman.iu-bremen.de/suse/10.1

Guru's packages repository:
ftp://ftp.gwdg.de/pub/linux/misc/suser-guru/rpm/10.1

I upgraded KDE to 3.5.2 'level a' and added all the packages I wanted from
Packman and Guru. I did all of this manually using YaST's "Software
Management" module.

Once everything was stable, I reinstalled the previously removed set of new
'online update' packages.

Then, from the KDE main menu, I selected 'System' > 'Configuration' and the
'Update Software' program. It launched, loaded in the taskbar and proceeded
to refresh the sources. This took about 10 minutes (1.5Mbit/512Kbit ADSL)
during which time it consumed, intermittently, 13% to 98% cpu... then it
calmed down completely. I 'hover' my mouse pointer over the taskbar icon and
it reports "There are no software updates available".

I've set it now to load automatically when I boot and log into KDE. It seems
to be running correctly now and I'm happy with it. Maybe, immediately after
installation, these programs try to accomplish too much, too soon
(concurrently, too) spoiling the new user's experience?

By performing the software additions and updates manually, I made it possible
for these utilities to initialize and run (or 'sync') under a very light
load.

< Previous Next >
References