Mailinglist Archive: opensuse (5130 mails)

< Previous Next >
Re: [SLE] Nvidia / AV Out Not Center
  • From: Shawn Holland <sholland@xxxxxxxxxx>
  • Date: Fri, 19 May 2006 12:06:32 -0300
  • Message-id: <200605191206.32946.sholland@xxxxxxxxxx>
On Thursday 18 May 2006 1:17 pm, Rikard Johnels wrote:
> What resolution/depth do you try to use now?
I'm currently using Desktop 768x576 (Pal) x24
And Monitor shows in SaX2 as --->Vesa 800x600x60khz

> What does the logs say? Any relevant errors or warnings?
SaX2.log:

============================
Framebuffer Info:
----------------------------

mode "800x600-75"
# D: 48.001 MHz, H: 46.876 kHz, V: 75.121 Hz
geometry 800 600 800 600 16
timings 20833 96 32 16 4 96 4
rgba 5/11,6/5,5/0,0/0
endmode


Frame buffer device information:
Name : VESA VGA
Address : 0xc0000000
Size : 3840000
Type : PACKED PIXELS
Visual : TRUECOLOR
XPanStep : 0
YPanStep : 0
YWrapStep : 0
LineLength : 1600
Accelerator : No

19-May 09:04:38 <X> Startup...
19-May 09:04:38 <X> [ Startup on already running Server:
:0.0 -> grant
]
19-May 09:04:39 <I> Imported: Card
19-May 09:04:39 <I> Imported: Desktop
19-May 09:04:39 <I> Imported: Pointers
19-May 09:04:39 <I> Imported: Keyboard
19-May 09:04:39 <I> Imported: Layout
19-May 09:04:40 <I> Imported: Path
19-May 09:04:40 <I> Imported: Extensions

> Is the display shifted in runlevel three? (Non X) Is it shifted with

No its fine in 3

> another manager (like twm or gonme)

I only installed KDE

> What happens if you change colour depth?

Color depth doesn't seem to have any effect. But adjusting the desktop
resolution changes the possition of the screen. But it is always not center
and sifted to the top right. As a note I had the same problem on my old
toshiba laptop wiht av-out. Never bothered to look further into it at that
time.

Also adjusting the monitor resolution doesn't work. It just imediately drops
out of SaX2


> What does your xorg.conf file look like?

Section "ServerFlags"
Option "AllowMouseOpenFail"
EndSection

Section "Module"
Load "glx"
Load "type1"
Load "extmod"
Load "dbe"
Load "freetype"
Load "v4l"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Device" "/dev/input/mice"
Option "Name" "PS/2 Generic Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
EndSection

Section "Monitor"
DisplaySize 300 230
HorizSync 28-38
Identifier "Monitor[0]"
ModelName "800X600@60HZ"
Option "DPMS"
VendorName "--> VESA"
VertRefresh 50-60
UseModes "Modes[0]"
EndSection

Section "Modes"
Identifier "Modes[0]"
Modeline "800x600" 36.88 800 832 912 1024 600 601 604 621
Modeline "768x576" 33.74 768 792 872 976 576 577 580 596
Modeline "640x480" 23.06 640 656 720 800 480 481 484 497
EndSection

Section "Screen"
DefaultDepth 24
SubSection "Display"
Depth 15
Modes "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "800x600" "768x576" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "800x600" "768x576" "640x480"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection

Section "Device"
BoardName "GeForce2 Ti"
BusID "1:0:0"
Driver "nv"
Identifier "Device[0]"
Screen 0
VendorName "NVidia"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection

Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection


If there is anymore info that I can provide to assist please let me know.

--
Regards,

Shawn Holland

< Previous Next >
Follow Ups