Mailinglist Archive: opensuse (5130 mails)

< Previous Next >
Re: [SLE] VMware 32bit/64bit mix
  • From: Hans du Plooy <hansdp-lists@xxxxxxxxxxx>
  • Date: Sat, 20 May 2006 17:04:55 +0200
  • Message-id: <1148137495.18377.8.camel@xxxxxxxxxxxxxxxxxxxxxxxx>
On Thu, 2006-05-18 at 15:25 +0200, Hans du Plooy wrote:
> Maybe I'm over enthusiastic, but I was wondering. I'm running 32bit
> SUSE 10.1 on a 64bit machine. I know I can't run 64bit binaries on
> 32bit OS, but is it possible to run a 64bit guest OS inside VMware? I
> mean, is the x86_64 instruction set available to VMware?

OK, I decided to discard this idea. I setup VMware on SUSE 10.1, fired
it up, and guess what? There was a suspended 64bit SUSE still open. So
I thought, what the heck, let's tried it. Hit resume, and it worked!
This is 64bit guess OS on a 32bit host OS running on 64bit hardware...

I tried a few things in it, all seem to work well (mostly command line
stuff), shut the machine down. Booted it again, and that worked fine,
except my keyboard is dead.

So the possibility is there...

Hans



< Previous Next >
References