Mailinglist Archive: opensuse (5130 mails)

< Previous Next >
RC2_RC3 update: package validation failed.
  • From: "Carlos E. R." <robin.listas@xxxxxxxxxxxxxx>
  • Date: Mon, 1 May 2006 01:33:31 +0200 (CEST)
  • Message-id: <Pine.LNX.4.61.0605010018340.613@xxxxxxxxxxxxxxxx>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1


I had installed 10.1 RC2 from scratch. Then yesterday I updated to RC3,
using the DVD made from the five CDs. At the start of the package
installation (dvd phase), I got this message in a pop up message box:

(X) Validation Check Failed

File content
is signed with the following GnuPG key, but the integrity check failed:

ID: A84EDAE89C800ACA
Fingerprint: 79C1 79B2 E1C8 20C1 890F 9994 A84E DAE8 9C80 0ACA
Name: SuSE package Signing Key <build@xxxxxxx>

This means that the file has been changed by accident or by an attacker
since the repository creator signed it. Using it is a big risk
for the integrity ans security of your system.

Use it anyway?

I clicked "yes", but I don't know which exact rpm is the wrong one.

Looking now at the yast logs (which I saved), I find messages related to
the incident:

2006-04-29 12:36:37 <0> linux(2913) [zypp] ExternalProgram.cc(start_program):280 pid 3215 launched
2006-04-29 12:36:37 <1> linux(2913) [zypp::KeyRing] KeyRing.cc(publicKeys):431 Found key [A84EDAE89C800ACA] [SuSE Package Signing Key <build@xxxxxxx>] [79C179B2E1C820C1890F9994A84EDAE89C800ACA]
...
2006-04-29 12:36:37 <0> linux(2913) [zypp] ExternalProgram.cc(start_program):170 Executing 'gpg' '--quiet' '--no-tty' '--no-greeting' '--no-permission-warning' '--batch' '--homedir' '/var/tmp/TmpDir.qMTSDH' '-a' '--export' 'A84EDAE89C800ACA'
...
2006-04-29 12:36:37 <1> linux(2913) [zypp::KeyRing] KeyRing.cc(verifyFileSignatureWorkflow):255 Key A84EDAE89C800ACA SuSE Package Signing Key <build@xxxxxxx> is trusted

the messages repeats several times. In fact, I got the the pop message box
at least twice during the phase running from the CD, and 3 or 4 times more
later when it booted and continued the install from the HD.


At the online update phase of the install, I got another error; this one I
could not copy to a png file, beacue print screen key did not work on this
phase, so I had to copy by hand:

Dependency conflict
patch zypp-1285-0.noarch [20060429-201531] can not be installed due to a missing...
(out of screen, couldn't see the rest)
there are no providers of zmd==7.0.1.0-12 for patch zypp

I selected "ignore" and it continued; but next time I looked back it was
asking the same thing, with two identical conflicts. I ignored again. This
time I watched the screen and I noticed that it said that yast has been
updated and needed to be restarted, so it did and looped back to the
online update, this time with a conflict of three identical packages! So
this time I canceled and continued the install.

I keep full logs of the incidents.

/var/log/YaST2/badlist:

2 packages failed
patch:zypp-1285-0.noarch[20060429-201531] cannot be installed due to missing dependencies
patch:zypp-1285-0.noarch[http://gd.tuwien.ac.at/linux/suse.com/suse/update/10.1/] cannot be installed due to missing dependencies


/var/log/YaST2/y2log-1

2006-04-29 20:15:31 <1> earendil(3977) [zypp::SourceManager] SourceManager.cc(sourceTableAdd):106 SourceManager add Source[4|YUM|20060429-201531]{http://gd.tuwien.ac.at/linux/suse.com/suse/update/10.1/(/)}
...

2006-04-29 20:16:51 <0> earendil(3977) [solver] QueueItemRequire.cc(process):586 Unfulfilled requirement '[atom] (namedcap) libzypp-zmd-backend == 7.1.1.0-17'. trying different solution
2006-04-29 20:16:51 <0> earendil(3977) [solver] ResolverQueue.cc(processOnce):269 did something: 3 qitems
2006-04-29 20:16:51 <0> earendil(3977) [solver] ResolverQueue.cc(spew):416 Resolver Queue:
2006-04-29 20:16:51 <0> earendil(3977) [solver] ResolverQueue.cc(spew):424 [Uninstall: UITh_[patch]zypp-1285-0.noarch (unsatisfied dependency), Triggered By [atom] (namedcap) libzypp-zmd-backend == 7.1.1.0-17]
2006-04-29 20:16:51 <0> earendil(3977) [solver] ResolverQueue.cc(spew):424 [Uninstall: UITh_[patch]zypp-1285-0.noarch (unsatisfied dependency), Triggered By [atom] (namedcap) libzypp == 0.0.8-105]
2006-04-29 20:16:51 <0> earendil(3977) [solver] ResolverQueue.cc(spew):424 [Uninstall: UITh_[patch]zypp-1285-0.noarch (unsatisfied dependency), Triggered By [atom] (namedcap) zmd == 7.1.1.0-12]
2006-04-29 20:16:51 <2> earendil(3977) [solver] ResolverContext.cc(addError):1161 ******** Error: ResolverInfo<NO_PROVIDER> patch:zypp-1285-0.noarch[20060429-201531] Error!>>There are no installable providers of zmd == 7.1.1.0-12 for patch:zypp-1285-0.noarch[20060429-201531]<<, Trigger: none
2006-04-29 20:16:51 <2> earendil(3977) [solver] ResolverContext.cc(addError):1161
2006-04-29 20:16:51 <2> earendil(3977) [solver] ResolverContext.cc(addError):1161 ******** Error: ResolverInfo<NO_PROVIDER> patch:zypp-1285-0.noarch[20060429-201531] Error!>>There are no installable providers of libzypp == 0.0.8-105 for patch:zypp-1285-0.noarch[20060429-201531]<<, Trigger: none


Does any of this ring a bell?


- --
Cheers,
Carlos Robinson
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)
Comment: Made with pgp4pine 1.76

iD8DBQFEVUlctTMYHG2NR9URAnygAJ9ZrxU2gvftUZoZsxK1BlA1Wdhy0ACeKmQt
jVAuMCQk9N2arXl7IwgQkzo=
=89Ck
-----END PGP SIGNATURE-----


< Previous Next >
List Navigation
Follow Ups